Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153959 - grpck is misparsing gshadow file
Summary: grpck is misparsing gshadow file
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: shadow-utils
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-06 03:04 UTC by Charles R. Anderson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-06 08:35:02 UTC


Attachments (Terms of Use)
works for me with shadow-utils-4.0.7-5 from devel (deleted)
2005-04-06 08:34 UTC, Peter Vrabec
no flags Details

Description Charles R. Anderson 2005-04-06 03:04:43 UTC
Description of problem:

grpck always fails with errors like "shadow group bin: no user oot".

Version-Release number of selected component (if applicable):
4.0.3-56

How reproducible:
always

Steps to Reproduce:
1. run "grpck"
2. don't let it "fix" the gshadow file
3.
  
Actual results:

#grpck
shadow group bin: no user oot
delete member `oot'? n
shadow group daemon: no user
delete member `'? n
shadow group daemon: no user
delete member `'? n
shadow group daemon: no user ot
delete member `ot'? n
shadow group daemon: no user in
delete member `in'? n
shadow group sys: no user oot
delete member `oot'? n
shadow group sys: no user t

Comment 1 Peter Vrabec 2005-04-06 08:34:28 UTC
Created attachment 112749 [details]
works for me with shadow-utils-4.0.7-5 from devel


Note You need to log in before you can comment on or make changes to this bug.