Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153942 - USB mouse feezes after a week or two on Dell P370
Summary: USB mouse feezes after a week or two on Dell P370
Keywords:
Status: CLOSED DUPLICATE of bug 149015
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-06 00:21 UTC by David Houlder
Modified: 2015-01-04 22:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-01 00:10:01 UTC


Attachments (Terms of Use)

Description David Houlder 2005-04-06 00:21:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
After running X for a week or two, the USB mouse will freeze, with no apparent pattern of behaviour or provocation. PS2 keyboard still works. Switching to a console with ctl-alt-F1 and back to X with ctl-alt-F7 fixes it, and then it's right again for another week it seems. Tried two different mice (Microsoft wheel mouse and the Dell wheel mouse that came with the P370), and it happens with both. I also tried uplugging/replugging the mouse once, and that fixed it for a few minutes only. I looked in dmesg, /var/log/Xorg.0.log and /var/log/messages.  The only mossages of note seem to be these that are due to switching to/from the console, and are seen regardless of whether the mouse is frozen or not.

from Xorg.0.log:
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) NVIDIA(0): Setting mode "1280x1024"
(II) Mouse0: ps2EnableDataReporting: succeeded

from /var/log/messages:
Apr  5 17:10:38 dh gpm[3754]: *** info [mice.c(1766)]: 
Apr  5 17:10:38 dh gpm[3754]: imps2: Auto-detected intellimouse PS/2

I'm using the Nvidia proprietary video driver, for what it's worth.

May be related to this URL:
http://www.linuxquestions.org/questions/history/287058

Might also be related to
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=149015
in EL4. Next time I have to reboot I will check the bios to make sure USB->PS2 Emulation is off and report back.




Version-Release number of selected component (if applicable):
kernel-2.6.10-1.770_FC3

How reproducible:
Always

Steps to Reproduce:
1. Start X session.
2. Stay in X session for a week or two until mouse freezes.
3. ctl-alt-f1 to get console, ctl-alt-f7 to get back to X.
4. mouse works normally for another week or so. 
  

Actual Results:  mouse froze, then thawed.

Expected Results:  should never freeze

Additional info:

Comment 1 David Houlder 2005-06-01 00:10:01 UTC
OK, I switched off USB->PS2 emulation in the BIOS a few months back and the
problem hasn't occurred since. Looks like it's a BIOS glitch.

*** This bug has been marked as a duplicate of 149015 ***


Note You need to log in before you can comment on or make changes to this bug.