Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153940 - RFE: FLAC support
Summary: RFE: FLAC support
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: bmp
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ralf Ertzinger
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-05 23:38 UTC by Zuirdj
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-28 09:11:01 UTC


Attachments (Terms of Use)

Description Zuirdj 2005-04-05 23:38:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Firefox/1.0.2 Fedora/1.0.2-3

Description of problem:
Since xmms goes to extras and maybe bmp will go to core, we need capability to read *.flac format in bmp.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. launch bmp
2. try to play a *.flac file
3. not sound at all :-)
  

Additional info:

Comment 1 Ralf Ertzinger 2005-04-06 14:19:33 UTC
There is no "official" FLAC plugin for BMP right now, but a hacked up version of
xmms-flac exists. I will look into it and see if it is possible to make a
bmp-flac package from it. No promises, though.

Comment 2 Zuirdj 2005-04-06 15:31:16 UTC
Thanks for the effort.

Comment 3 Thorsten Leemhuis 2005-06-27 15:29:26 UTC
This would require that flac would be in extras -- is that legally possible?
afaik not, but maybe I'm wrong

Comment 4 Ralf Ertzinger 2005-06-27 15:34:07 UTC
FLAC is in Core.

Comment 5 Thorsten Leemhuis 2005-06-27 15:45:50 UTC
/me was confused: faac != flac

Sorry

Comment 6 Matthias Saou 2005-07-22 13:43:47 UTC
Any news on this? Ralf : Had time to hack some more on the plugin?

Comment 7 Ralf Ertzinger 2005-07-30 18:00:00 UTC
The hacked-up version is a major mess. I have written a new version from scratch
which has today produced the first recognizable stream of audio from a .flac
file, so it is time to release it onto the unsuspecting public.
Get the tarball here:

http://www.skytale.net/files/bmp-flac2/bmp-flac2-001.tar.gz

NOTE:
This is a source-only release, you will have to compile this yourself. The code
is alpha quality and misses features.
Read the README file before use.

Thanks.

Comment 8 Matthias Saou 2005-08-01 16:51:11 UTC
Maybe you should inform the bmp developers and have it listed on the official
plugins page so that it gets some testing from many users?

Comment 9 Ralf Ertzinger 2005-08-01 17:06:19 UTC
For the time being I'll be happy if it works for anyone besides me. The code is
not ready yet for broad distribution.

Comment 10 Ralf Ertzinger 2005-11-28 09:11:01 UTC
bmp-flac2 is available in Fedora Extras devel now.


Note You need to log in before you can comment on or make changes to this bug.