Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1539377 - SELinux is preventing sealert from read, write access on the Datei /var/lib/rpm/.dbenv.lock.
Summary: SELinux is preventing sealert from read, write access on the Datei /var/lib/r...
Keywords:
Status: CLOSED DUPLICATE of bug 1513720
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c637ca7d9e62687acea5ed36d8d...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-28 12:34 UTC by Dirk Gottschalk
Modified: 2018-02-07 09:15 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-07 09:15:33 UTC


Attachments (Terms of Use)

Description Dirk Gottschalk 2018-01-28 12:34:02 UTC
Description of problem:
SELinux is preventing sealert from read, write access on the Datei /var/lib/rpm/.dbenv.lock.

*****  Plugin restorecon (99.5 confidence) suggests   ************************

If you want to fix the label. 
/var/lib/rpm/.dbenv.lock default label should be rpm_var_lib_t.
Then you can run restorecon. The access attempt may have been stopped due to insufficient permissions to access a parent directory in which case try to change the following command accordingly.
Do
# /sbin/restorecon -v /var/lib/rpm/.dbenv.lock

*****  Plugin catchall (1.49 confidence) suggests   **************************

If you believe that sealert should be allowed read write access on the .dbenv.lock file by default.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
Do
allow this access for now by executing:
# ausearch -c 'sealert' --raw | audit2allow -M my-sealert
# semodule -X 300 -i my-sealert.pp

Additional Information:
Source Context                system_u:system_r:setroubleshoot_fixit_t:s0-s0:c0.
                              c1023
Target Context                system_u:object_r:var_lib_t:s0
Target Objects                /var/lib/rpm/.dbenv.lock [ file ]
Source                        sealert
Source Path                   sealert
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    <Unbekannt>
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.14.14-300.fc27.x86_64 #1 SMP Fri
                              Jan 19 13:19:54 UTC 2018 x86_64 x86_64
Alert Count                   1
First Seen                    2018-01-28 13:30:15 CET
Last Seen                     2018-01-28 13:30:15 CET
Local ID                      e163f389-0b9f-4ebb-bdb2-7bf5d0a7c0aa

Raw Audit Messages
type=AVC msg=audit(1517142615.812:1597): avc:  denied  { read write } for  pid=3979 comm="sealert" name=".dbenv.lock" dev="dm-0" ino=529440 scontext=system_u:system_r:setroubleshoot_fixit_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_lib_t:s0 tclass=file permissive=0


Hash: sealert,setroubleshoot_fixit_t,var_lib_t,file,read,write


Additional info:
component:      selinux-policy
reporter:       libreport-2.9.3
hashmarkername: setroubleshoot
kernel:         4.14.14-300.fc27.x86_64
type:           libreport

Comment 1 Panu Matilainen 2018-02-07 09:15:33 UTC

*** This bug has been marked as a duplicate of bug 1513720 ***


Note You need to log in before you can comment on or make changes to this bug.