Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153929 - Hang when adding a new printer
Summary: Hang when adding a new printer
Keywords:
Status: CLOSED DUPLICATE of bug 144167
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-05 21:34 UTC by Philippe Rigault
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-06 08:47:33 UTC


Attachments (Terms of Use)
/proc/bus/usb/devices (deleted)
2005-04-05 21:34 UTC, Philippe Rigault
no flags Details

Description Philippe Rigault 2005-04-05 21:34:49 UTC
Description of problem:     
system-config-printer hangs when clicking on 'New' to add a new printer. 
     
Version-Release number of selected component (if applicable):     
system-config-printer-0.6.116.1.4-1     
     
How reproducible: Always     
     
     
Steps to Reproduce:     
1. launch system-config-printer     
2. click on 'New'     
       
Actual results:     
$ system-config-printer     
*** glibc detected *** malloc(): memory corruption: 0x09aece50 ***     
sh: line 1:  9151 Abandon                 perl -e 'ioctl(STDIN,0x84005001,    
$result);print $result' 2>/dev/null </dev/usb/lp0     
Traceback (most recent call last):     
  File "/usr/share/printconf/util/queueTree.py", line 580, in     
new_button_clicked     
    self.addQueue.addQueueDruid ()     
  File "/usr/share/printconf/util/addQueue.py", line 248, in addQueueDruid     
    self.populate_device_view ()     
  File "/usr/share/printconf/util/addQueue.py", line 468, in     
populate_device_view     
    self.local_devs = self.parent.conf.scan_local_printer_devices (force)     
  File "/usr/share/printconf/util/printconf_conf.py", line 1288, in     
scan_local_printer_devices     
    local_printer_devices.device_dict[dev].update(autodetect_usb_printer(dev,     
i))     
  File "/usr/share/printconf/util/printconf_conf.py", line 1415, in     
autodetect_usb_printer     
    return { "auto" : auto }     
UnboundLocalError: local variable 'auto' referenced before assignment     
     
     
Expected results:     
Proceeds to enter a new printer     
     
Additional info:     
Dell Inspiron 5160     
kernel-2.6.10-1.770_FC3smp     
  
Output from  /proc/bus/usb/devices attached

Comment 1 Philippe Rigault 2005-04-05 21:34:49 UTC
Created attachment 112730 [details]
/proc/bus/usb/devices

Comment 2 Tim Waugh 2005-04-06 08:47:33 UTC

*** This bug has been marked as a duplicate of 144167 ***


Note You need to log in before you can comment on or make changes to this bug.