Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153771 - Logjam includes two different .desktop files
Summary: Logjam includes two different .desktop files
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: logjam
Version: rawhide
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-05 19:21 UTC by John Thacker
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-06 14:55:43 UTC


Attachments (Terms of Use)

Description John Thacker 2005-04-05 19:21:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Firefox/1.0.2 Fedora/1.0.2-3

Description of problem:
logjam includes two separate .desktop files:
/usr/share/applications/fedora-logjam.desktop
/usr/share/applications/logjam.desktop
This makes it show up twice in menus, etc.

Presumably the second one got added upstream or something?  Anyway, the *.desktop in the SPEC file catches both of them.

Version-Release number of selected component (if applicable):
logjam-4.4.1-5

How reproducible:
Always

Steps to Reproduce:
1. install logjam
2. view Applications/Internet GNOME menu
3. see two LogJam selections
alternately:
1. rpm -ql logjam
  

Actual Results:  Two logjam menu entries
[root@thacker jat48]# rpm -ql logjam
/usr/bin/logjam
/usr/share/applications/fedora-logjam.desktop
/usr/share/applications/logjam.desktop


Expected Results:  Only one .desktop file, only one menu entry.

Additional info:

Comment 1 Tom "spot" Callaway 2005-04-06 14:55:43 UTC
Good catch John. Fixed in devel, logjam-4.4.1-6 which is pending build.

Comment 2 John Thacker 2005-04-14 14:00:42 UTC
BTW, logjam-4.4.1-6 had a build failure.  Looks like the build system couldn't
find the replacement logjam.desktop file:
http://fedoraproject.org/extras/development/build-logs/i386/logjam-4.4.1-6.log

RPM build errors:
    Bad file: /usr/src/rpm/SOURCES/logjam.desktop: No such file or directory

Comment 3 Tom "spot" Callaway 2005-04-14 14:38:02 UTC
Yeah, I didn't fix it correctly. 4.4.1-7 is better tested, and pending build.


Note You need to log in before you can comment on or make changes to this bug.