Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153769 - nmap-frontend is built with gtk2, requires gtk+
Summary: nmap-frontend is built with gtk2, requires gtk+
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: nmap
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-05 19:14 UTC by John Thacker
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-21 14:26:58 UTC


Attachments (Terms of Use)

Description John Thacker 2005-04-05 19:14:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Firefox/1.0.2 Fedora/1.0.2-3

Description of problem:
Recently, nmap-frontend has been being built with an evil gtk2 port (-DGTK_ENABLE_BROKEN ugh!), but the spec file still requires gtk+, even when built using gtk2

Version-Release number of selected component (if applicable):
nmap-frontend-3.81-1

How reproducible:
Always

Steps to Reproduce:
1. yum install nmap-frontend on a box without gtk+, or
1. rpm --requires nmap-frontend

Actual Results:  Tries to pull in gtk+:
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for nmap-frontend to pack into transaction set.
nmap-frontend-3.81-1.i386 100% |=========================| 6.8 kB    00:00
---> Package nmap-frontend.i386 2:3.81-1 set to be updated
--> Running transaction check
--> Processing Dependency: gtk+ for package: nmap-frontend
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for gtk+ to pack into transaction set.
gtk%2B-1.2.10-33.i386.rpm 100% |=========================|  23 kB    00:00
---> Package gtk+.i386 1:1.2.10-33 set to be updated

or
shows the requirement of gtk+

Expected Results:  Shouldn't require gtk+

Additional info:

Comment 1 Harald Hoyer 2005-04-21 14:26:58 UTC
if you 'ugh!', then provide a better patch upstream instead of my quick
-DGTK_ENABLE_BROKEN

Comment 2 John Thacker 2005-04-21 14:52:57 UTC
"if you 'ugh!', then provide a better patch upstream instead of my quick
-DGTK_ENABLE_BROKEN"

Point taken, apologies if I offended.  It is a little bit of work to rewrite it
to use GtkTextView instead of GtkText; I can't guarantee I have the time.  I
prefer your patch to it still running gtk+-1.2, certainly.  No offense intended.

Comment 3 Harald Hoyer 2005-04-21 17:20:30 UTC
I fixed it by patching configure.in ... gtk+ dep removed now


Note You need to log in before you can comment on or make changes to this bug.