Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153754 - HTTP install fails (probably FTP too)
Summary: HTTP install fails (probably FTP too)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-05 16:56 UTC by Elliot Lee
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-15 04:33:45 UTC


Attachments (Terms of Use)

Description Elliot Lee 2005-04-05 16:56:45 UTC
With the FC4-re0404.0 tree

Traceback (most recent call last):
File /usr/bin/anaconda, line 1168 in ?
anaconda/text.py, line 497, in run
...
anaconda/packages.py, line 158, in readPackages
   hdrlist = method.readHeaders()
anaconda/urlinstall.py line 170 in readHeaders
  url = grabber.urlopen(hdurl, retry=5)
urlgrabber/grabber.py, line 444, in urlopen
  return default_grabber.urlopen(url, **kwargs)
urlgrabber/grabber.py, line 575, in urlopen
  return self._retry(opts, retryfunc, url)
urlgrabber/grabber.py, line 547, in _retry
urlgrabber/grabber.py, line 574, in retryfunc
urlgrabber/grabber.py, line 727, in __init__
urlgrabber/grabber.py, line 794, in _do_open
urlgrabber/grabber.py, line 885, in _make_request
urllib2.py, line 358, in open
urllib2.py, line 376, in _open
urllib2.py, line 337, in _call_chain
urllib2.py, line 213, in http_open
urlgrabber/keepalive.py, line 240, in do_open
urlgrabber/keepalive.py, line 315, in _start_transaction
    h.putrequest('GET', req.get_selector())
httplib.py, line 748, in putrequest.py
    self.putheader('Host', self.host.encode("idna"))
LookupError: unknown encoding: idna

Comment 1 Elliot Lee 2005-04-05 17:07:01 UTC
The cause of this problem is that /usr/lib*/python2.4/encodings/idna.* do not exist.

Comment 2 Elliot Lee 2005-04-05 17:16:34 UTC
Fix committed to CVS


Note You need to log in before you can comment on or make changes to this bug.