Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153745 - tg3 driver usage count is 0
Summary: tg3 driver usage count is 0
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-05 15:40 UTC by Need Real Name
Modified: 2015-01-04 22:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-05 23:43:41 UTC


Attachments (Terms of Use)

Description Need Real Name 2005-04-05 15:40:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3) Gecko/20050104 Red Hat/1.4.3-3.0.7

Description of problem:
"lsmod" showed tg3 was loaded and usage count was 0.
The nic is "Ethernet controller Broadcom Co. NetXtreme BCM 5751 Gigabit Ethernet PCI Express" intergrated on a Dell GX280".


Version-Release number of selected component (if applicable):
kernel 2.6.9-1.667smp

How reproducible:
Always

Steps to Reproduce:
1.Do a fresh install of FC3
2.configure the network eth0 use dhcp
3.boot up
4.verify network is working, 

  

Actual Results:  5."lsmod" shows "tg3   79045 0"

the usage count is 0

Expected Results:  expected to be >=1

Additional info:

since the usage count is 0, I can "rmmod tg3" to remove the module
and the network stoping working (and eth0 will no longer show up with "ifconfig -a").

Is this a bug, or a new feature of this driver?

Comment 1 Dave Jones 2005-04-05 23:43:41 UTC
its by design. all network drivers in 2.6 do this.


Note You need to log in before you can comment on or make changes to this bug.