Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153743 - Contact Management online doc is incorrect; LDAP setup instructions are wrong
Summary: Contact Management online doc is incorrect; LDAP setup instructions are wrong
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 168429
TreeView+ depends on / blocked
 
Reported: 2005-04-05 15:31 UTC by Howard Owen
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version: RHBA-2006-0002
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-07 18:31:26 UTC


Attachments (Terms of Use)
Proposed patch to the documentation (deleted)
2005-11-08 20:44 UTC, Dave Malcolm
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0002 qe-ready SHIPPED_LIVE evolution bug fix update 2006-03-06 05:00:00 UTC
GNOME Bugzilla 314804 None None None Never

Description Howard Owen 2005-04-05 15:31:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050322 Galeon/1.3.20

Description of problem:
Help -> Evolution Contacts -> LDAP -> Configuring points to 
Help -> Advanced -> Contact Management. The text here describes an assistant that doesn't exist. The Contacts -> New -> Contact List item is a single dialog that allows you to select names from an address book. It also doesn't include a way to configure an LDAP server as documented. The correct place to do that is Contacts -> New -> Address Book, which is also not an "assistant" but a two tab dialog in this case.

Version-Release number of selected component (if applicable):
evolution-2.0.2-14

How reproducible:
Always

Steps to Reproduce:
1. Navigate the online help to the indicated point
2. Compare the documentation to how the application operates.
3. Note disparity.

Actual Results:  Documentation is incorrect

Expected Results:  Documentation should give an accurate description of how to configure a new LDAP server. Correct documentation on creating a contact list should be provided, too.

Additional info:

Comment 1 Dave Malcolm 2005-08-29 23:02:42 UTC
Thanks for this bug report.

Yes, the 2.0 documentation is describing the old Evolution 1.4 (RHEL 3) way of
configuring LDAP addressbook access.  I've checked and this mistake is still
present in the very latest documentation from upstream (Evolution 2.3).  I've
filed this bug about the documentation upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=314804


Comment 5 Dave Malcolm 2005-11-08 20:44:52 UTC
Created attachment 120825 [details]
Proposed patch to the documentation

Attached patch:
(i) entirely removes the "config-prefs-contact" section (and references to it),
since the information there is either a poorly written duplicate of information
available elsewhere in the document, or is wrong
(ii) fills out the section on configuring LDAP with fresh information, based
upon how the dialog actually looks in RHEL4, whilst attemptint to stay true to
the style of markup in the rest of the documentation

Comment 12 Red Hat Bugzilla 2006-03-07 18:31:27 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0002.html



Note You need to log in before you can comment on or make changes to this bug.