Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153741 - gulm init script should not fail if tag doesn't exist in cluster.conf
Summary: gulm init script should not fail if tag doesn't exist in cluster.conf
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: gulm
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam "mantis" Manthei
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-05 15:29 UTC by Corey Marthaler
Modified: 2009-04-16 19:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-20 18:32:55 UTC


Attachments (Terms of Use)

Description Corey Marthaler 2005-04-05 15:29:21 UTC
Description of problem:
Starting lock_gulmd:  no <gulm> section detected in /etc/cluster/cluster.conf
[FAILED]

A better messages might be:
Starting lock_gulmd: Skipping because no <gulm> section detected in
/etc/cluster/cluster.conf  [OK]


Version-Release number of selected component (if applicable):
[root@tank-03 ~]# lock_gulmd -V
lock_gulmd 1.0-0.pre26 (built Mar 28 2005 18:04:15)
Copyright (C) 2004 Red Hat, Inc.  All rights reserved.

How reproducible:
everytime

Comment 1 Adam "mantis" Manthei 2005-04-05 15:40:33 UTC
Except for the fact that lock_gulmd didn't actually startup.  "OK" is just as
wrong as "FAILED".

Trouble shooting working systems that are reporting failures are easier to deal
with than broken systems reporting success.

Will look into a different error message to appease both camps

Comment 2 Adam "mantis" Manthei 2005-04-13 21:15:43 UTC
gulm init.d script now prints WARNING instead of FAILURE.

Checking in gulm/init.d/lock_gulmd;
/cvs/cluster/cluster/gulm/init.d/lock_gulmd,v  <--  lock_gulmd
new revision: 1.1.2.8; previous revision: 1.1.2.7


Comment 3 Corey Marthaler 2005-04-14 20:27:01 UTC
where did the "no <gulm> section detected in /etc/cluster/cluster.conf" go?

Now it just says:
Starting lock_gulmd:[WARNING]

Comment 4 Adam "mantis" Manthei 2005-04-20 16:39:21 UTC
> where did the "no <gulm> section detected in /etc/cluster/cluster.conf" go?
The warning message is sent to syslog.

Since lock_gulmd does not start, it should not print "OK".  It instead fails to
start in a manor that is determined to be acceptable (hence why it's exit status
is 0 and not 1) but in a way that still provides the user with a clue that they
might have a configuration problem.

The bug states that lock_gulmd should not fail, so it doesn't.  It just provides
the user with feedback to start looking into what the problem might be.  If they
don't like that message, they should disable lock_gulmd with chkconfig.

It is my opinion that this will be much easier to trouble shoot than pretending
that everything is OK.  

Comment 5 Corey Marthaler 2005-04-20 18:32:55 UTC
I see the message in the syslog, fix verified.


Note You need to log in before you can comment on or make changes to this bug.