Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1537186 - Smartstate won't show applications for Windows VM
Summary: Smartstate won't show applications for Windows VM
Keywords:
Status: CLOSED DUPLICATE of bug 1519910
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis
Version: 5.8.0
Hardware: All
OS: All
unspecified
medium
Target Milestone: GA
: cfme-future
Assignee: Jerry Keselman
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-22 16:10 UTC by David Luong
Modified: 2018-01-22 16:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-22 16:36:10 UTC
Category: Bug
Cloudforms Team: CFME Core


Attachments (Terms of Use)

Description David Luong 2018-01-22 16:10:54 UTC
Description of problem:
Smartstate won't show applications for Windows VM

Version-Release number of selected component (if applicable):
5.8.x

How reproducible:
Always for the customer

Steps to Reproduce:
1.  Perform SSA on a Windows VM on vCenter
2.  SmartState scan is not showing applications
3.

Actual results:
SmartState scan is not showing applications

Expected results:
SmartState scan shows applications

Additional info:
[----] E, [2018-01-16T08:29:15.708797 #7221:529130] ERROR -- : MIQExtract.extract undefined method `split' for nil:NilClass
[----] E, [2018-01-16T08:29:15.708982 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/manageiq-gems-pending-dd41a2772297/lib/gems/pending/metadata/util/win32/Win32Software.rb:161:in `block in initialize'
[----] E, [2018-01-16T08:29:15.709033 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/manageiq-gems-pending-dd41a2772297/lib/gems/pending/util/xml/xml_hash.rb:116:in `block in each_element'
[----] E, [2018-01-16T08:29:15.709075 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/manageiq-gems-pending-dd41a2772297/lib/gems/pending/util/xml/xml_hash.rb:111:in `block in each'
[----] E, [2018-01-16T08:29:15.709116 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/manageiq-gems-pending-dd41a2772297/lib/gems/pending/util/xml/xml_hash.rb:111:in `each'
[----] E, [2018-01-16T08:29:15.709157 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/manageiq-gems-pending-dd41a2772297/lib/gems/pending/util/xml/xml_hash.rb:111:in `each'
[----] E, [2018-01-16T08:29:15.709198 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/manageiq-gems-pending-dd41a2772297/lib/gems/pending/util/xml/xml_hash.rb:116:in `each_element'
[----] E, [2018-01-16T08:29:15.709240 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/manageiq-gems-pending-dd41a2772297/lib/gems/pending/metadata/util/win32/Win32Software.rb:155:in `initialize'
[----] E, [2018-01-16T08:29:15.709281 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/manageiq-gems-pending-dd41a2772297/lib/gems/pending/metadata/MIQExtract/MIQExtract.rb:253:in `new'
[----] E, [2018-01-16T08:29:15.709322 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/manageiq-gems-pending-dd41a2772297/lib/gems/pending/metadata/MIQExtract/MIQExtract.rb:253:in `getSoftware'
[----] E, [2018-01-16T08:29:15.709384 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/manageiq-gems-pending-dd41a2772297/lib/gems/pending/metadata/MIQExtract/MIQExtract.rb:136:in `block in extract'
[----] E, [2018-01-16T08:29:15.709429 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/manageiq-gems-pending-dd41a2772297/lib/gems/pending/metadata/MIQExtract/MIQExtract.rb:131:in `each'
[----] E, [2018-01-16T08:29:15.709471 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/manageiq-gems-pending-dd41a2772297/lib/gems/pending/metadata/MIQExtract/MIQExtract.rb:131:in `extract'
[----] E, [2018-01-16T08:29:15.709511 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/mixins/scanning_mixin.rb:252:in `block in scan_via_miq_vm'
[----] E, [2018-01-16T08:29:15.709552 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/mixins/scanning_mixin.rb:248:in `each'
[----] E, [2018-01-16T08:29:15.709606 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/mixins/scanning_mixin.rb:248:in `scan_via_miq_vm'
[----] E, [2018-01-16T08:29:15.709649 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/manageiq-providers-vmware-58e20bf9862e/app/models/manageiq/providers/vmware/infra_manager/vm_or_template_shared/scanning.rb:29:in `perform_metadata_scan'
[----] E, [2018-01-16T08:29:15.709691 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_server/server_smart_proxy.rb:125:in `scan_metadata'
[----] E, [2018-01-16T08:29:15.709732 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_queue.rb:347:in `block in deliver'
[----] E, [2018-01-16T08:29:15.709772 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:91:in `block in timeout'
[----] E, [2018-01-16T08:29:15.709813 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:33:in `block in catch'
[----] E, [2018-01-16T08:29:15.710392 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:33:in `catch'
[----] E, [2018-01-16T08:29:15.710439 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:33:in `catch'
[----] E, [2018-01-16T08:29:15.710481 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:106:in `timeout'
[----] E, [2018-01-16T08:29:15.710521 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_queue.rb:343:in `deliver'
[----] E, [2018-01-16T08:29:15.710562 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:107:in `deliver_queue_message'
[----] E, [2018-01-16T08:29:15.710617 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:135:in `deliver_message'
[----] E, [2018-01-16T08:29:15.710659 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:153:in `block in do_work'
[----] E, [2018-01-16T08:29:15.710700 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:147:in `loop'
[----] E, [2018-01-16T08:29:15.710739 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:147:in `do_work'
[----] E, [2018-01-16T08:29:15.710781 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker/runner.rb:340:in `block in do_work_loop'
[----] E, [2018-01-16T08:29:15.710821 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker/runner.rb:337:in `loop'
[----] E, [2018-01-16T08:29:15.710862 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker/runner.rb:337:in `do_work_loop'
[----] E, [2018-01-16T08:29:15.710908 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker/runner.rb:160:in `run'
[----] E, [2018-01-16T08:29:15.710951 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker/runner.rb:134:in `start'
[----] E, [2018-01-16T08:29:15.710991 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker/runner.rb:21:in `start_worker'
[----] E, [2018-01-16T08:29:15.711031 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker.rb:339:in `block in start_runner'
[----] E, [2018-01-16T08:29:15.711071 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/gems/nakayoshi_fork-0.0.3/lib/nakayoshi_fork.rb:24:in `fork'
[----] E, [2018-01-16T08:29:15.711111 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/gems/nakayoshi_fork-0.0.3/lib/nakayoshi_fork.rb:24:in `fork'
[----] E, [2018-01-16T08:29:15.711152 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker.rb:337:in `start_runner'
[----] E, [2018-01-16T08:29:15.711192 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker.rb:348:in `start'
[----] E, [2018-01-16T08:29:15.711232 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker.rb:266:in `start_worker'
[----] E, [2018-01-16T08:29:15.711271 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker.rb:150:in `block in sync_workers'
[----] E, [2018-01-16T08:29:15.711312 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker.rb:150:in `times'
[----] E, [2018-01-16T08:29:15.711352 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker.rb:150:in `sync_workers'
[----] E, [2018-01-16T08:29:15.711392 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_server/worker_management/monitor.rb:53:in `block in sync_workers'
[----] E, [2018-01-16T08:29:15.711433 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_server/worker_management/monitor.rb:50:in `each'
[----] E, [2018-01-16T08:29:15.711473 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_server/worker_management/monitor.rb:50:in `sync_workers'
[----] E, [2018-01-16T08:29:15.711513 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_server/worker_management/monitor.rb:22:in `monitor_workers'
[----] E, [2018-01-16T08:29:15.711554 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_server.rb:349:in `block in monitor'
[----] E, [2018-01-16T08:29:15.711626 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/manageiq-gems-pending-dd41a2772297/lib/gems/pending/util/extensions/miq-benchmark.rb:11:in `realtime_store'
[----] E, [2018-01-16T08:29:15.711673 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/manageiq-gems-pending-dd41a2772297/lib/gems/pending/util/extensions/miq-benchmark.rb:30:in `realtime_block'
[----] E, [2018-01-16T08:29:15.711715 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_server.rb:349:in `monitor'
[----] E, [2018-01-16T08:29:15.711756 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_server.rb:371:in `block (2 levels) in monitor_loop'
[----] E, [2018-01-16T08:29:15.711797 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/manageiq-gems-pending-dd41a2772297/lib/gems/pending/util/extensions/miq-benchmark.rb:11:in `realtime_store'
[----] E, [2018-01-16T08:29:15.711837 #7221:529130] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/manageiq-gems-pending-dd41a2772297/lib/gems/pending/util/extensions/miq-benchmark.rb:30:in `realtime_block'
[----] E, [2018-01-16T08:29:15.711878 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_server.rb:371:in `block in monitor_loop'
[----] E, [2018-01-16T08:29:15.711919 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_server.rb:370:in `loop'
[----] E, [2018-01-16T08:29:15.711965 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_server.rb:370:in `monitor_loop'
[----] E, [2018-01-16T08:29:15.712484 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_server.rb:253:in `start'
[----] E, [2018-01-16T08:29:15.712532 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/lib/workers/evm_server.rb:65:in `start'
[----] E, [2018-01-16T08:29:15.712601 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/lib/workers/evm_server.rb:91:in `start'
[----] E, [2018-01-16T08:29:15.712650 #7221:529130] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/lib/workers/bin/evm_server.rb:4:in `<main>'
[----] E, [2018-01-16T08:29:15.712813 #7221:529130] ERROR -- : MIQ(ManageIQ::Providers::Vmware::InfraManager::Vm#scan_via_miq_vm) Error: No XML returned for category [software]  TaskId:[18bdada4-fac1-11e7-91bb-00505693b8cb]  VM:[XXXXXXX]

Possibly related:

https://github.com/ManageIQ/manageiq-smartstate/issues/5

Comment 2 Jared Deubel 2018-01-22 16:36:10 UTC

*** This bug has been marked as a duplicate of bug 1519910 ***


Note You need to log in before you can comment on or make changes to this bug.