Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153718 - No dualhead on nv cards
Summary: No dualhead on nv cards
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
: 218416 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-05 09:30 UTC by Need Real Name
Modified: 2018-04-11 08:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-06 19:58:32 UTC


Attachments (Terms of Use)
output from lspci (deleted)
2005-04-05 09:31 UTC, Need Real Name
no flags Details
output from dmesg (deleted)
2005-04-05 09:32 UTC, Need Real Name
no flags Details
minimal (single screen) xorg config (deleted)
2005-04-05 09:33 UTC, Need Real Name
no flags Details
s-c-d's dual head config (deleted)
2005-04-05 09:37 UTC, Need Real Name
no flags Details
Xorg.0.log (deleted)
2005-04-05 09:38 UTC, Need Real Name
no flags Details

Description Need Real Name 2005-04-05 09:30:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050322 Epiphany/1.5.8

Description of problem:
I have an nvidia card with both a digital and analog out, one for each screen.
Installing FC4T1 gives me two screens that are identical.

I ran system-config-display to setup dual head, and this fails.
It failed so badly that I resorted to unpluggin the dvi cord, and running system-config-display --reconfig. That failed too.

I'll attach the output from lspci and dmesg.

It would be really good if this worked - I'm not using the binary nvidia driver.
It would also be good to have a --failsafe option that gives people a low res usable screen on one monitor.

If you need anything else for this, let me know!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:

Comment 1 Need Real Name 2005-04-05 09:31:31 UTC
Created attachment 112702 [details]
output from lspci

Comment 2 Need Real Name 2005-04-05 09:32:02 UTC
Created attachment 112703 [details]
output from dmesg

Comment 3 Need Real Name 2005-04-05 09:33:01 UTC
Created attachment 112704 [details]
minimal (single screen) xorg config

Comment 4 Need Real Name 2005-04-05 09:37:57 UTC
Created attachment 112705 [details]
s-c-d's dual head config

Comment 5 Need Real Name 2005-04-05 09:38:40 UTC
Created attachment 112706 [details]
Xorg.0.log

..and here are the errors from the X server.

*deep breath*

Sorry for all the attachments.

Comment 6 Need Real Name 2005-04-08 21:27:48 UTC
Any possiblity of some help on this one?

Comment 7 Søren Sandmann Pedersen 2005-04-28 20:59:12 UTC
This will have to be punted to FC5 along with all the other dual head bugs.

Comment 8 Need Real Name 2005-04-28 21:19:54 UTC
Fair enough. It's not exactly a quick fix.

Comment 9 Adam Jackson 2006-03-03 15:28:51 UTC
Mass update: move dual head bugs from FC5 to FC6, no way they can get fixed
before FC5 release at this point.

Comment 10 Matthias Clasen 2006-07-06 21:46:52 UTC
Add to FC6Destop tracker

Comment 11 Adam Jackson 2006-07-26 15:59:35 UTC
Oops, nvidia card.

The nv driver has no support for dual-head at all, so there's not really any way
to fix this within system-config-display.  It's been a requested enhancement
with Xorg for a while now, but no one has stepped up to do it.

We should at least be smart enough to refuse to attempt dualhead setup on nv though.

Comment 12 Matthias Clasen 2006-11-26 18:45:44 UTC
Update version according to the latest comments.

Comment 13 Adam Jackson 2007-03-26 20:40:40 UTC
I'm kicking this to the nv driver for lack of dualheadedness.  s-c-d UI
deficiencies are covered elsewhere.

Comment 14 Adam Jackson 2007-04-02 20:44:35 UTC
*** Bug 218416 has been marked as a duplicate of this bug. ***

Comment 17 Adam Jackson 2007-09-06 19:58:32 UTC
F7 now has rudimentary dualhead support for G70 and below, and RANDR 1.2
dualhead support for G80 cards.


Note You need to log in before you can comment on or make changes to this bug.