Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153684 - libgcj should Provide jaxp_parser_impl
Summary: libgcj should Provide jaxp_parser_impl
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat
Version: 4
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Thomas Fitzsimmons
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-04 23:27 UTC by Robin Green
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-15 19:19:42 UTC


Attachments (Terms of Use)

Description Robin Green 2005-04-04 23:27:12 UTC
Description of problem:
The libgcj rpm should be listed as Providing jaxp_parser_impl, because it
contains gnujaxp. Otherwise yum will presumably unnecessarily look for an
alternative jaxp implementation.

Version-Release number of selected component (if applicable):
libgcj-4.0.0-0.38

How reproducible:
Every time

Steps to Reproduce:
1. rpm -q --provides libgcj
  
Actual results:
lib-gnu-java-awt-peer-gtk.so.6
libgcj.so.6
libgcj4
libgij.so.6
libjawt.so.6
libgcj = 4.0.0-0.38

Expected results:
The above plus
jaxp_parser_impl


Additional info:

Comment 2 Thomas Fitzsimmons 2005-04-05 15:57:04 UTC
This is tricky because some packages require specific 

Comment 3 Thomas Fitzsimmons 2005-04-05 16:00:07 UTC
jaxp parser implementations.  This generic virtual provides comes from JPackage
and I'm not sure it's a good idea.  I think we should change packages that
require xalan and xerces to explicitly require them.  And we should maybe create
a "sdk_jaxp_parser" virtual provide for packages that want to explicitly require
the built-in parser implementation.


Comment 4 Robin Green 2005-04-05 16:02:48 UTC
I think jaxp_parser_impl is useful for dependencies for packages which don't
care which implementation of jaxp they use.

Comment 5 Thomas Fitzsimmons 2005-04-05 16:41:18 UTC
True.  Another possibility is that I could add this Provides to java-gcj-compat.
 Gary, what are the implications of doing this for packages that need xerces/xalan?

Comment 6 Gary Benson 2005-04-06 14:19:56 UTC
I'm not sure.  Applications that use xerces make sure that xerces is the XML
parser by having xerces-j2.jar in the classpath; there's a bunch of files in
that jar's META-INF/services directory that point to various classes that are
loaded by reflection.  How are libgcj's classes discovered?  libgcj.jar doesn't
contain the META-INF/services stuff, so I'm guessing that libgcj's stuff is
loaded as a default when nothing else is found.  If that's the case then it
shouldn't be a problem.

Also I think java-gcj-compat is a better place for the alternatives stuff than
libgcj.

Comment 7 Thomas Fitzsimmons 2005-04-15 19:19:42 UTC
OK, I've added:

Provides: jaxp_parser_impl

to java-gcj-compat.  This will land in Rawhide tomorrow, closing.



Note You need to log in before you can comment on or make changes to this bug.