Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153676 - libbfd.a has bugs, libbfd.so works
Summary: libbfd.a has bugs, libbfd.so works
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: binutils
Version: 2
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-04 21:37 UTC by aaron scamehorn
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-05 10:43:27 UTC


Attachments (Terms of Use)
Test program (deleted)
2005-04-04 21:37 UTC, aaron scamehorn
no flags Details

Description aaron scamehorn 2005-04-04 21:37:57 UTC
Description of problem:  Static version of libbfd is broken (libbfd.so is good
however).


Version-Release number of selected component (if applicable): Part of
binutils-2.15.90.0.3-5


How reproducible:
Write a test program to call bfd_fdopenr() on a FILE (exe, lib, etc).  

Steps to Reproduce:
1.  Link test program w/ libbfd.a
2. Run program
3.
  
Actual results:
Examine the bfd pointer returned from this call.  Among many other things, the
bfd->name value is null, bfd->next is null, flags are null. 

Expected results:
bfd->name should point to the first section of the FILE as reported by objdump
-h FILE.
bfd->sections should not be null.
bfd->flags should not be zero


Additional info:
-OR- Statically link objdump w/ libbfd.a; it should break.

Comment 1 aaron scamehorn 2005-04-04 21:37:57 UTC
Created attachment 112688 [details]
Test program

Comment 2 Jakub Jelinek 2005-04-05 10:43:27 UTC
Can't reproduce with binutils-2.15.92.0.2-5.


Note You need to log in before you can comment on or make changes to this bug.