Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153658 - grep -qE ...\B in /etc/init.d/autofs : not right
Summary: grep -qE ...\B in /etc/init.d/autofs : not right
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: autofs
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Feist
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-04 19:48 UTC by Will Partain
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-04 21:53:11 UTC


Attachments (Terms of Use)
Patch to set LC_ALL in the init script (deleted)
2005-04-04 21:15 UTC, Chris Feist
no flags Details | Diff

Description Will Partain 2005-04-04 19:48:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.6) Gecko/20050321 Firefox/1.0.2

Description of problem:
The use of \B (instead of \b?) in a few places in /etc/init.d/autofs just
looks plain wrong.  I found this when I added --debug onto a line in
/etc/auto.master, and the option failed to get picked up.  What ultimately
happens comes down to what's in this tiny script:

#!/bin/sh -x
echo "--debug" | grep -qE -- '\B-(d\b|-debug\b)'
echo $?


Version-Release number of selected component (if applicable):
autofs--4.1.3-28

How reproducible:
Always

Steps to Reproduce:
1.  sh -x /etc/init.d/autofs any-command
2.  look out for an action like that above
3.
  

Actual Results:  as described

Expected Results:  as described

Additional info:

Comment 1 Chris Feist 2005-04-04 21:15:44 UTC
Created attachment 112686 [details]
Patch to set LC_ALL in the init script

It appears the problem is being caused by LC_ALL not being set in your init
script.  This is fixed in future autofs RPMS and can be fixed in your
installation by applying the patch to your /etc/init.d/autofs init script.

Comment 2 Chris Feist 2005-04-04 21:17:51 UTC
Please let us know by filing a comment in this bug if the fix works for you.

Comment 3 Will Partain 2005-04-04 21:43:54 UTC
Yes, the fix works.  (And makes my head hurt :-)  Nice work.


Note You need to log in before you can comment on or make changes to this bug.