Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1534025 - SUI: Enabling expression does not work for Custom Button defined on ServiceTemplate
Summary: SUI: Enabling expression does not work for Custom Button defined on ServiceTe...
Keywords:
Status: CLOSED DUPLICATE of bug 1509959
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - Service
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.9.1
Assignee: Allen W
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-12 20:39 UTC by Yuri Rudman
Modified: 2018-01-19 15:10 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-19 15:10:25 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
Button Customization: Enablement Expression (deleted)
2018-01-12 20:39 UTC, Yuri Rudman
no flags Details
Button is active on SSUI (deleted)
2018-01-12 20:40 UTC, Yuri Rudman
no flags Details
Button is disabled on Classic UI (deleted)
2018-01-12 20:42 UTC, Yuri Rudman
no flags Details
DB dump (deleted)
2018-01-18 16:25 UTC, Yuri Rudman
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1534004 None None None Never

Internal Links: 1534004

Description Yuri Rudman 2018-01-12 20:39:14 UTC
Created attachment 1380513 [details]
Button Customization: Enablement Expression

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Create Service Template and Service
2. Create Custom Button in Button Group for Service Template   (Services->Catalogs->All Catalog Items -> Action ... )
3.Assign enabling expression which should be evaluated to false to created button: "Service Catalog Item : Prov Type = "hello""
4. In SSUI navigate to "My Services" -> Click on tested service
(screenshots attached)

Actual results: Custom Button is active and executing action on click


Expected results: Disabled Custom Button


Additional info:
Classic UI does not have this issue - button disabled

Comment 2 Yuri Rudman 2018-01-12 20:40:50 UTC
Created attachment 1380514 [details]
Button is active on SSUI

Comment 3 Yuri Rudman 2018-01-12 20:42:03 UTC
Created attachment 1380515 [details]
Button is disabled on Classic UI

Comment 6 Yuri Rudman 2018-01-18 16:25:27 UTC
Created attachment 1382971 [details]
DB dump

Comment 8 Allen W 2018-01-19 13:16:54 UTC
Lookin' at this now 💖

Comment 10 Allen W 2018-01-19 13:56:19 UTC
Dan, ya ok with closing this, given its a notahbug?

Comment 12 Allen W 2018-01-19 15:05:45 UTC
I found it, I found it, was a thing recently fixed, why we're not seeing it 
https://github.com/ManageIQ/manageiq-ui-service/pull/1239

so really this is a dupe of 
https://bugzilla.redhat.com/show_bug.cgi?id=1509959

Comment 13 Yuri Rudman 2018-01-19 15:10:25 UTC

*** This bug has been marked as a duplicate of bug 1509959 ***


Note You need to log in before you can comment on or make changes to this bug.