Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1533486 - Credential validation error message is not user friendly, for RHV providers supporting api version 4
Summary: Credential validation error message is not user friendly, for RHV providers s...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.10.0
Assignee: Boriso
QA Contact: Angelina Nikiforova
URL:
Whiteboard: rhev:ux
Depends On:
Blocks: 1534566
TreeView+ depends on / blocked
 
Reported: 2018-01-11 13:33 UTC by Ilanit Stein
Modified: 2019-04-02 08:24 UTC (History)
7 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1534566 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:27:29 UTC
Category: Bug
Cloudforms Team: RHEVM
Target Upstream Version:


Attachments (Terms of Use)

Description Ilanit Stein 2018-01-11 13:33:50 UTC
Description of problem:
Add RHV-4.1 provider to CFME with wrong password, and press "validate" or
Edit a RHV provider that CFME is already connected, and has valid credentials: Enter a wrong password, and press "validate".
The error that will appear in the UI will be:

"Credential validation was not successful: MiqException::MiqInvalidCredentialsError"

Running the same or RHV-3.6, generate a more "friendly" error message:
"Credential validation was not successful: Incorrect user name or password."

Please change the error for RHV providers, that supports api version 4 (like RHV-4.1), to be the same error as for providers that support api version 3 (like RHV-3.6).

Version-Release number of selected component (if applicable):
CFME-5.9.0.16/RHV-4.1.8
(Compared to RHV-3.6.12-4)

How reproducible:
100%

Comment 3 CFME Bot 2018-01-15 05:30:26 UTC
New commit detected on ManageIQ/manageiq-providers-ovirt/master:
https://github.com/ManageIQ/manageiq-providers-ovirt/commit/fa726364ea4667f204db7691af915982bc04846e

commit fa726364ea4667f204db7691af915982bc04846e
Author:     Boris Odnopozov <bodnopoz@redhat.com>
AuthorDate: Sun Jan 14 12:32:02 2018 +0200
Commit:     Boris Odnopozov <bodnopoz@redhat.com>
CommitDate: Sun Jan 14 12:32:02 2018 +0200

    Fix message for credentials validation
    
    Fix message for credentials validation
    Fixes: https://bugzilla.redhat.com/show_bug.cgi?id=1533486

 app/models/manageiq/providers/redhat/infra_manager/api_integration.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


Note You need to log in before you can comment on or make changes to this bug.