Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1533356 - StreamingAPI- SDK - add the ability to create an ISO disk container as it exist in REST
Summary: StreamingAPI- SDK - add the ability to create an ISO disk container as it ex...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.2.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.2.1
: ---
Assignee: Tal Nisan
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks: 1511420
TreeView+ depends on / blocked
 
Reported: 2018-01-11 07:13 UTC by Avihai
Modified: 2018-02-12 11:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-12 11:50:16 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+
rule-engine: exception+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 86353 None None None 2018-01-15 12:53:27 UTC

Description Avihai 2018-01-11 07:13:03 UTC
Description of problem:
Add the ability to create an ISO disk container via SDK as in REST.
Currently, this option does not exist.

I use python-ovirt-engine-sdk4-4.2.2-2.el7.centos.x86_64 ( which is the latest I could find in bob) .

From /usr/lib64/python2.7/site-packages/ovirtsdk4/types.py -> Class Disk  -> Only the following kwargs exist:

class Disk(Device):

    def __init__(
        self,
        active=None,
        actual_size=None,
        alias=None,
        bootable=None,
        comment=None,
        description=None,
        disk_profile=None,
        format=None,
        id=None,
        image_id=None,
        initial_size=None,
        instance_type=None,
        interface=None,
        logical_name=None,
        lun_storage=None,
        name=None,
        openstack_volume_type=None,
        permissions=None,
        propagate_errors=None,
        provisioned_size=None,
        qcow_version=None,
        quota=None,
        read_only=None,
        sgio=None,
        shareable=None,
        snapshot=None,
        sparse=None,
        statistics=None,
        status=None,
        storage_domain=None,
        storage_domains=None,
        storage_type=None,
        template=None,
        total_size=None,
        uses_scsi_reservation=None,
        vm=None,
        vms=None,
        wipe_after_delete=None,
    ):

In REST:

create an ISO disk container in the REST-API exit within the request:

<disk>
 ....
 <content_type>iso</content_type>
 ....
</disk>



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Tal Nisan 2018-01-11 09:29:24 UTC
The SDK is not yet updated to use the new model, will keep this bug open as a tracker for the issue and will update when it is taken care of

Comment 2 Allon Mureinik 2018-01-15 13:11:12 UTC
Tal, I assume the API/SDK is self-documenting, so we don't need any additional docs here, right?
(marking "requires-doctext?" until the needinfo is answered, just to stay on the safe side).

Comment 3 Tal Nisan 2018-01-15 13:19:30 UTC
Yes, all is documented in the API docs

Comment 4 RHV Bugzilla Automation and Verification Bot 2018-01-18 17:39:16 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[No relevant external trackers attached]

For more info please contact: infra@ovirt.org

Comment 5 RHV Bugzilla Automation and Verification Bot 2018-01-24 22:07:52 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[No relevant external trackers attached]

For more info please contact: infra@ovirt.org

Comment 6 Avihai 2018-01-31 13:44:44 UTC
verified at 4.2.1.3-0.1.el7.

Comment 7 Sandro Bonazzola 2018-02-12 11:50:16 UTC
This bugzilla is included in oVirt 4.2.1 release, published on Feb 12th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.