Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153300 - RHEL5-rg-bug: Multiple minor corrections / typos in rhel-rg
Summary: RHEL5-rg-bug: Multiple minor corrections / typos in rhel-rg
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhel-rg
Version: 4.5
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Michael Hideo
QA Contact: John Ha
URL: http://www.redhat.com/docs/manuals/en...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-04 16:35 UTC by Stephen Gardner
Modified: 2014-08-04 22:15 UTC (History)
2 users (show)

Fixed In Version: RHEL4.5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-24 01:39:28 UTC


Attachments (Terms of Use)

Description Stephen Gardner 2005-04-04 16:35:37 UTC
Version-Release number of selected component (if applicable):
RHEL4-Reference Guide
Version: rhel-rg(EN)-4-HTML-RHI (2004-09-30T17:13)

1.4.2   Runlevel Utilities

        Error Type: incorrect command location
        Priority: medium

            /sbin/ntsysv   is now located at   /usr/sbin/ntsysv

        [ no symlink exists either, this old location was correct in RHEL3 ]
        [ appears elsewhere in rhel-rg, search for /sbin/ntsysv throughout ]
        [ ntsysv referred to inconsistently within the rhel-rg with and    ]
        [ without path prefix                                              ]

2.6     Grub Commands, Paragraph detailing "kernel" option

        Error Type: consistency
        Priority: low

            paragraph should probably refer to 
            "root=/dev/VolGroup00/LogVol00"  not  "/dev/hda5" or "hda5"
            and examples should be
            "kernel /vmlinuz-2.6.8-1.523 ro root=/dev/VolGroup00/LogVol00"
            to be consistent with Section 2.7.1 et al.

            Removal of references to kernel version 2.4.21 throughout.


3.2.1.14 The /var/ Directory

        Error Type: typo
        Priority: ultra-low

            "System log files, such as messages/ and lastlog/"   probably should
be changed to 
            "System log files, such as messages and lastlog"

            because these are filenames not directory names.


5.3.9.3  /proc/sys/kernel

        Error Type: non-default option referred to
        Priority: low

            Under "cap-bound" (and other sections) of the documentation 
            says
            
            "For a valid list of values for this virtual file, refer to the 
            following installed documentation:
            /lib/modules/<kernel-version>/build/include/linux/capability.h."

        The file referred to is part of the kernel-devel package which is 
        not part of the default installation set. The statement should 
        include a reference to the kernel-devel package


5.3.9.4 /proc/sys/net

        Error Type: reference to unsupported option
        Priority: ultra-low

            "such as appletalk/, ethernet/, ipv4/"..  should change to 
            "such as ethernet/, ipv4/"..

        RHEL4 does not support appletalk and even though this is only an 
        example people who use appletalk may go looking for appletalk elsewhere 
        in the docs.


14.9.4. Useful Websites

        Error Type: Specific version number should be made generic
        Priority: ultra-low

            "samba-3.0.3"...   replace with 
            "samba-<versionnumber>"...

        For reference RHEL4 ships with 3.0.10.


17.1    TCP Wrappers

        Error Type: Bad example in Note section
        Priority: medium

           The Note for determining if a network service users TCP wrappers is
outdated as 
           most RHEL4 service are dynamically (not statically) linked with TCP
wrappers.
           
           The example
               "strings -f <binary-name> | grep hosts_access"

           won't detect all services which use TCP wrappers. Perhaps 
           
           ldd <binary-name> |grep libwrap
           
           would I believe catch a high proportion of wrappered services
           but neither method is 100%.


19.5    Configuring a Kerberos 5 Server (paragraph numbered 1.)

        Error Type: Old URL used
        Priority: low

           The official home page for NTP has changed from 
           http://www.eecis.udel.edu/~ntp     to
           http://www.ntp.org


20.6    Requiring SSH for Remote Connections

        Error Type: Old reference
        Priority: ultra-low

            redhat-config-services   change to
            system-config-services

         I think this has happened everywhere else in the docs.


A.3. Ethernet Parameters

        Error Type: Old reference
        Priority: ultra-low

            modules.conf   should be replaced with   modprobe.conf


Document Wide:
         You could consider search for "2.6.8-1.523" and aim to replace 
         them with "2.6.9-5.EL" throughout as that's the kernel version 
         RHEL4-U0 shipped with but I realise its almost always used as 
         an example.

Comment 2 Mike Behm 2006-02-06 14:30:24 UTC
All requested changes have been made except for:

5.3.9.3  /proc/sys/kernel

        Error Type: non-default option referred to
        Priority: low

            Under "cap-bound" (and other sections) of the documentation 
            says
            
            "For a valid list of values for this virtual file, refer to the 
            following installed documentation:
            /lib/modules/<kernel-version>/build/include/linux/capability.h."

        The file referred to is part of the kernel-devel package which is 
        not part of the default installation set. The statement should 
        include a reference to the kernel-devel package

>> Can you suggest an appropriate package?

Another change not yet made is this:

Document Wide:
         You could consider search for "2.6.8-1.523" and aim to replace 
         them with "2.6.9-5.EL" throughout as that's the kernel version 
         RHEL4-U0 shipped with but I realise its almost always used as 
         an example.

>> Are there kernel changes between updates that make such changes difficult
>> to maintain properly?


Comment 3 Don Domingo 2007-04-16 07:07:41 UTC
fixes verified in source. reassigning to mhideo to have updated built document
pushed to docs site. 

thanks!

Comment 4 Don Domingo 2007-05-29 01:26:04 UTC
changing to MODIFIED, to be CLOSEDCURRENTRELEASE when pushed to docs site

Comment 5 Michael Hideo 2007-10-23 02:50:34 UTC
Removing automation notification


Note You need to log in before you can comment on or make changes to this bug.