Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153298 - language.py line 30 in expandLangs: iterable argument required
Summary: language.py line 30 in expandLangs: iterable argument required
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-04 16:31 UTC by Ricky Ng-Adam
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-15 04:30:04 UTC


Attachments (Terms of Use)

Description Ricky Ng-Adam 2005-04-04 16:31:56 UTC
Description of problem:

Again, Anaconda is broken in the same file (language.py) as bug 152533:

anaconda: 1117
kickstart.py: 1454
kickstart.py: 836
kickstart.py: 595
installclass.py line 360
language.py line 227 in setSupported
language.py: line 30, in expandLangs
  if '.' in astring:
TypeError: iterable argument required

Version-Release number of selected component (if applicable):

anaconda-10.2.0.37

How reproducible:

always

Steps to Reproduce:
1. pxe boot
2. kickstart install
3.
  
Actual results:

installation eventually crash.

Expected results:

installation completes normally.

Additional info:

[rsync'ed from mirror.dulug.duke.edu 2005/04/04 12:30PM EST]

Should I expect both:

install
lang en_US.UTF-8
langsupport --default=en_CA.UTF-8 en_CA.UTF-8 fr_CA.UTF-8
keyboard us

and

install
lang fr_CA.UTF-8
langsupport --default=fr_CA.UTF-8 fr_CA.UTF-8 fr_CA.UTF-8
keyboard us

kickstart install to work when this is fixed? I'd like to test french install to
look at the strings.

Comment 1 Ricky Ng-Adam 2005-04-06 02:36:08 UTC
Different error now with en_US.UTF-8:

File "/usr/lib/anaconda/kickstart.py". line 220, in skipStep
  raise KeyError, ("unknown step %s" % stepToSkip)
KeyError: 'unknown step languagesupport'

...and fr_CA:

File "/usr/lib/anaconda/language.py", line 147, in getLangNameByNick
  return self.localeInfo[curNick][0]
KeyError

Comment 2 Ricky Ng-Adam 2005-04-06 02:38:03 UTC
Comment #1 was with anaconda-10.2.0.40-1 BTW...

Comment 3 Chris Lumens 2005-04-06 14:30:06 UTC
The unknown step error was fixed in 10.2.0.41-1.  The KeyError on fr_CA is
because I'm not finished rewriting language support yet.  For now if you want to
just examine the strings, you'll need to use something like fr_FR.


Note You need to log in before you can comment on or make changes to this bug.