Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153292 - DDC probe failed on ATI Radeon 9000
Summary: DDC probe failed on ATI Radeon 9000
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rhpl
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-04 15:23 UTC by Telsa Gwynne
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-11 15:04:17 UTC


Attachments (Terms of Use)

Description Telsa Gwynne 2005-04-04 15:23:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041020

Description of problem:
Perhaps as a result of a text-based install, the X server starts
up as 16-bit 800x600. I do not know what "DDC probe failed"
means, but apparently that's what happened. 

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install fc4test1 in text mode (I couldn't find a mouse at the time) on
Athlon box with Radeon 9000.
2. No questions are asked about display, monitor, resolution, etc.
3. Reboot
4. See graphical login and realise you are going to need a mouse: acquire one :)
 

Actual Results:  The X server starts up in 16-bit 800x600 mode. 

Expected Results:  I expected 1280x1024 and "millions of colours". 

Additional info:

Comment 1 Mike A. Harris 2005-04-11 11:16:08 UTC
Install time DDC probe only works on 32bit x86 if I'm not mistaken, unless
ddcprobe utility was changed from using LRMI to something that works on
other architectures.

If this is still the case, then DDC probing is not possible by the installer.
The X server still does DDC probing however.

This is a problem that will become more and more of an issue as time goes
on and requires our configuration tools to be re-engineered.

Reassigning to rhpl, which currently contains the ddcprobe utility.

Comment 2 Jeremy Katz 2005-04-11 15:04:17 UTC
We default to 16-bit 800x600.  firstboot has the bits to change X configuration
(and you didn't get firstboot due to the bugs previously discussed, so ... :)


Note You need to log in before you can comment on or make changes to this bug.