Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153285 - text install did not offer language selections for post-install
Summary: text install did not offer language selections for post-install
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-04 14:26 UTC by Telsa Gwynne
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-05 16:07:27 UTC


Attachments (Terms of Use)

Description Telsa Gwynne 2005-04-04 14:26:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041020

Description of problem:



Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
Athlon machine. Burned CDs and did text install (because the
box is going to be used remotely and had no mouse attached)

It asked me what language I wanted to perform the install in.
I picked Welsh. It did not ask me (a) what other languages I 
wanted; or (b) what language I wanted the system to run in.

After a successful install, it booted up in English. Logging in,
I found my locale was POSIX. 

Actual Results:  Installed successfully, but all the boot messages were in English.
Logging in as root, I found my locale was POSIX. root has no 
.i18n. 

Complicating matters, /etc/sysconfig/i18n says
SUPPORTED=cy_GB.UTF-8:cy_GB:cy

I do not know when this was set to this. After logging in
as root, I created a proper user and logged in as that, telling
gdm I wanted Welsh. I don't know whether that changed
the /etc file. (I'm not sure it should have done, surely..?)

Expected Results:  I would have expected a "what languages do you want on the
machine?" option and a further "which of these do you want to
be the default?". Neither appeared. 

Additional info:

Comment 1 Jens Petersen 2005-04-05 15:42:34 UTC
There is a Language Support package group under Package Customization now.

Comment 2 Jeremy Katz 2005-04-05 16:07:27 UTC
/etc/sysconfig/i18n wasn't getting created for any installs for a while (oops).
 This should be fixed up now.  Additional language support is now done in
package selection (since that's what you're really selecting) and this allows it
to be added more easily post-install as well.  The default language for
post-install is the language you did your install in.  The dichotomy between the
two has always been weird :)

So the main bug is fixed, the other stuff is just moved around.

Comment 3 Telsa Gwynne 2005-04-06 14:53:43 UTC
I'm not sure I follow (sorry). 

Do you mean that this is what will happen in test2 and onwards, 
or that I should have seen a Language Support package group 
somewhere in the install in test1? 

If the latter, then I should mention that I didn't see any such 
package group. I got a choice of things like "X", "Gnome" "DNS
Server" "Java Development", but there was nothing about languages
in there. And there was no option to refine things within those
groups. 

If the former, well, then, I'll try again when we get fc4t2 :) 


Note You need to log in before you can comment on or make changes to this bug.