Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153282 - Fails to load some jpg images
Summary: Fails to load some jpg images
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libexif
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
: 154388 (view as bug list)
Depends On:
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2005-04-04 14:00 UTC by Steven Usdansky
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-25 02:50:08 UTC


Attachments (Terms of Use)
file won't load in gimp-2.2.4-10 (deleted)
2005-04-04 16:03 UTC, Steven Usdansky
no flags Details

Description Steven Usdansky 2005-04-04 14:00:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Firefox/1.0.2 Fedora/1.0.2-3

Description of problem:
Some of my jpg images fail to load. Error msg: 
Opening '/home/a/images/Dsc03596.jpg' failed:
Plug-In could not open image

Version-Release number of selected component (if applicable):
2.2.4-10

How reproducible:
Sometimes

Steps to Reproduce:
1. Load gimp
2. Click File - Open
3. Select jpg image and hit Enter key

  

Actual Results:  Get error message

Expected Results:  Image should load

Additional info:

Not sure why certain images load and others do not. Images that fail to load in gimp do load properly in gthumb-2.6.4-2 and eog-2.10.0-1. libexif version is 2.6.12-1. Images that fail in gimp-2.2.4-10 do load properly using gimp and libexif from FC4t1 iso. Not sure when in the update process this problem first occurred.

Comment 1 Nils Philippsen 2005-04-04 14:50:38 UTC
Please attach an example image.

Comment 2 Steven Usdansky 2005-04-04 16:03:04 UTC
Created attachment 112659 [details]
file won't load in gimp-2.2.4-10

Comment 3 Nils Philippsen 2005-04-08 14:18:07 UTC
To me, this seems to be a problem with the newer libexif. Running the gimp like
this:

[nils@cognac ~]$ gimp --stack-trace-mode query tmp/gimp-2.2.4-wontload.jpg
/usr/lib/gimp/2.0/plug-ins/jpeg: fatal error: Segmentation fault
/usr/lib/gimp/2.0/plug-ins/jpeg (pid:6828): [E]xit, [H]alt, show [S]tack trace
or [P]roceed: h

you can attach your favourite debugger to the jpeg plugin process, this gives
such a backtrace:

(gdb) where
#0  0x005188a2 in g_on_error_query () from /usr/lib/libglib-2.0.so.0
#1  0x00eb1414 in gimp_plugin_sigfatal_handler (sig_num=11) at gimp.c:1473
#2  <signal handler called>
#3  0x00e47c08 in exif_data_save_data_content (data=0x8bedc18, ifd=0x8becdf0,
d=0xbf9ba910, ds=0xbf9ba910, offset=8) at exif-data.c:241
#4  0x00e484c2 in exif_data_save_data (data=0x8bedc18, d=0xbf9ba910,
ds=0xbf9ba90c) at exif-data.c:839
#5  0x0804c70d in load_image (filename=0x8bec4a8
"/home/nils/tmp/gimp-2.2.4-wontload.jpg", runmode=Variable "runmode" is not
available.
) at jpeg.c:1297
#6  0x0804dc41 in run (name=0x8bec3e8 "file_jpeg_load", nparams=3,
param=0x8bec438, nreturn_vals=0xbf9bab44, return_vals=0xbf9bab48) at jpeg.c:460
#7  0x00eb245d in gimp_main (info=0x8051460, argc=6, argv=0xbf9bac14) at gimp.c:1772
#8  0x0804b236 in main (argc=-1357250552, argv=0xaf1a0008) at jpeg.c:327
#9  0x0059dde6 in __libc_start_main () from /lib/libc.so.6
#10 0x0804b181 in _start ()

The real SEGV happens in exif_data_save_data_entry() at exif-data.c:241, which
is inlined from exif_data_save_data_content() at exif-data.c:460.

Matthias, can you please investigate what goes wrong here?

Comment 4 Nils Philippsen 2005-04-11 15:12:30 UTC
*** Bug 154388 has been marked as a duplicate of this bug. ***

Comment 5 Matthias Clasen 2005-04-21 17:25:48 UTC
http://bugs.gentoo.org/show_bug.cgi?id=86740 has a patch for this.

Comment 6 Matthias Clasen 2005-04-25 02:50:08 UTC
Fixed in 0.6.12-2


Note You need to log in before you can comment on or make changes to this bug.