Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1532807 - Targeted Refresh is not triggered
Summary: Targeted Refresh is not triggered
Keywords:
Status: CLOSED DUPLICATE of bug 1519214
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: All
OS: All
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Sam Lucidi
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-09 20:12 UTC by Giovanni Fontana
Modified: 2018-02-20 15:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-19 21:33:14 UTC
Category: ---
Cloudforms Team: Openstack


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github ManageIQ manageiq issues 16759 None None None 2018-01-09 20:15:44 UTC

Description Giovanni Fontana 2018-01-09 20:12:19 UTC
Description of problem:

Targeted Refresh is not triggered, even with inventory_object_refresh and allow_targeted_refresh enabled. 

Version-Release number of selected component (if applicable): 5.9.0 - I tested with ManageIQ beta release gaprindashvili-1-rc1, but I suppose the same apply to CF 4.6 Beta.

How reproducible: 
Yes


Steps to Reproduce:
1. Make sure that properties inventory_object_refresh and allow_targeted_refresh are enabled.
2. Provision a new instance using a OpenStack provider.
3. Note that even with those properties enabled the full refresh is used.

Actual results:
Full refresh is scheduled.

Expected results:
Targeted refresh for a particular Instance.

Additional info:
I made a deep dive into the code and I discovered the possible cause of this issue. I posted it into the manageiq github. See in the following link: https://github.com/ManageIQ/manageiq/issues/16759

Comment 2 Marek Aufart 2018-01-11 11:41:09 UTC
This should have been fixed by https://bugzilla.redhat.com/show_bug.cgi?id=1519214#c3  (point 4 of the comment - so it's propably dupe BZ).

Comment 3 Giovanni Fontana 2018-01-11 13:25:32 UTC
Great news Makek! Thank you very much! Do you know in which version this fix should be included?

Regards!

Comment 4 Sam Lucidi 2018-02-19 21:33:14 UTC

*** This bug has been marked as a duplicate of bug 1519214 ***


Note You need to log in before you can comment on or make changes to this bug.