Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153280 - kernel panic ide drivers already locked
Summary: kernel panic ide drivers already locked
Keywords:
Status: CLOSED DUPLICATE of bug 144743
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-04 13:46 UTC by Charles Bronson
Modified: 2015-01-04 22:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-04 07:11:55 UTC


Attachments (Terms of Use)

Description Charles Bronson 2005-04-04 13:46:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Description of problem:
If I boot an earlier kernel, everything is fine but when I boot 2.6.10-1.770_FC3 the text below is output and then the system hangs there:

Booting 'Fedora Core (2.6.10-1.770_FC3)'

root(hd0,0)
 Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.10-1.770_FC3 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
   [Linux-bzImage, setup=0x1400, size=0x163d2f]
initrd /initrd-2.6.10-1.770_FC3.img
   [Linux-initrd @ 0x1feee000, 0xecb84 bytes]

Uncompressing Linux... Ok, booting the kernel.
audit(1111834312.913:0): initialized
Red Hat nash version 4.1.18 starting
  Reading all physical volumes. This may take a while...
  Found volume group "VolGroup00" using metadata type lvm2
  2 logical volume(s) in volume group "VolGroup00" now active
Kernel panic - not synching: drivers/ide/pci/piix.c:232: spin_lock(drivers/ide/ide.c:c036e408) already locked by drivers/ide/ide-iops.c/1222


Version-Release number of selected component (if applicable):
Kernel 2.6.10-1.770_FC3

How reproducible:
Always

Steps to Reproduce:
1. Boot with the 2.6.10-1.770_FC3 kernel.
2.
3.
  

Actual Results:  kernel panic is displayed and system hangs.

Expected Results:  Normal boot.

Additional info:

Comment 1 Peter Lawler 2005-04-24 05:17:17 UTC
See bug #144743

Comment 2 Dave Jones 2005-06-04 07:11:55 UTC

*** This bug has been marked as a duplicate of 144743 ***


Note You need to log in before you can comment on or make changes to this bug.