Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153275 - rsync uses bandwidth despite not doing anything
Summary: rsync uses bandwidth despite not doing anything
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rsync
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Simo Sorce
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-04 12:37 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-12 18:25:02 UTC


Attachments (Terms of Use)

Description Need Real Name 2005-04-04 12:37:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Epiphany/1.4.4

Description of problem:
rsync -av something/local 192.168.1.1:/home/username/something/remote/

building file list ... done
rsync: recv_generator: mkdir "local": Permission denied (2)
stat local : No such file or directory

The rsync continues, although /home/username/something/remote/ remains empty.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
x

Additional info:

Comment 1 Need Real Name 2006-01-20 21:03:47 UTC
The same problem occurs if a usb device is unplugged.
rsync will continue syncing (say) a hard disk and a usb disk, without any errors.

Bizarre.

Comment 2 Simo Sorce 2007-08-10 16:40:37 UTC
Sorry for the late reply, but this behavior is completely expected.
Closing.

Comment 3 Need Real Name 2007-08-10 21:20:23 UTC
If this bug is completley expected, despite it being reported as being
completley unexpected, you need to explain why before marking it as NOTABUG.

Comment 4 Simo Sorce 2007-08-12 18:25:02 UTC
1. If you don't have the permission to write on the remote system, I expect
rsync not being able to. It correctly reports an error, and goes on with the
files trying to see if there is something it can actually sync over.

2. if you unplug a usb disk you just unmount a filesystem, but that does not
make the mount point unwritable, the mount point just becomes a normal directory
so if you rsync over it you are just copying files in a normal directory,
provided you have permission to write on it I don't see why should it fail at all.

The bug report also shows that rsync actually reports an error, so you are
warned something is wrong.

This is basic unix knowledge applied to the situation, that's why it is
completely expected.

closing again unless you have evidence of a misbehavior.

Comment 5 Need Real Name 2007-08-12 18:30:18 UTC
In reply to comment #1:
Well the problem is that the usb drive died during the rsync.

In reply to the bug:
If rsync doesn't have write access to the top-level directory, then everything
will fail. It's missing a short-circuit.


Note You need to log in before you can comment on or make changes to this bug.