Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153271 - ntpd SEGV's on start about 70% of the time. About 30% of the time it works correctly.
Summary: ntpd SEGV's on start about 70% of the time. About 30% of the time it works c...
Keywords:
Status: CLOSED DUPLICATE of bug 151262
Alias: None
Product: Fedora
Classification: Fedora
Component: ntp
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jiri Ryska
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-04 11:02 UTC by Russell Coker
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-10 17:20:37 UTC


Attachments (Terms of Use)

Description Russell Coker 2005-04-04 11:02:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.0 (like Gecko)

Description of problem:
I installed FC4T1 with no relevant configuration changes apart from setting   
the NTP server to use my own local NTP server instead of pool.ntp.org.  Most   
of the time it SEGTV's shortly after startup but occasionally it works   
correctly.   
   
Here is a GDB trace of the ntpd startup:   
Program received signal SIGSEGV, Segmentation fault.   
0x00edd0cb in __printf_fp () from /lib/tls/libc.so.6   
(gdb) bt   
#0  0x00edd0cb in __printf_fp () from /lib/tls/libc.so.6   
#1  0x00eda21c in vfprintf () from /lib/tls/libc.so.6   
#2  0x00f76965 in __vsnprintf_chk () from /lib/tls/libc.so.6   
#3  0x0090aeb9 in receive () from /usr/sbin/ntpd   
#4  0x008d5173 in main () from /usr/sbin/ntpd   
   
The NTP server that it is talking to is running Debian.  
 
This may be related to #145258 

Version-Release number of selected component (if applicable):
ntp-4.2.0.a.20040617-7

How reproducible:
Sometimes

Steps to Reproduce:
Repeatedly run /etc/init.d/ntpd stop ; /etc/init.d/ntpd start on a FC4T1 
machine and it should happen. 
 

Actual Results:  Most of the time it doesn't start correctly, ntpd SEGV's shortly after 
startup. 

Additional info:

Comment 1 Russell Coker 2005-04-10 17:20:37 UTC

*** This bug has been marked as a duplicate of 151262 ***


Note You need to log in before you can comment on or make changes to this bug.