Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153267 - File Associations for Evolution 2.0.4 running in KDE for MS Word attachments will not relate to MS Word running in CrossoverOffice
Summary: File Associations for Evolution 2.0.4 running in KDE for MS Word attachments ...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
: 153270 153273 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-04 09:53 UTC by Mike Cohler
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-11-21 16:29:28 UTC


Attachments (Terms of Use)

Description Mike Cohler 2005-04-04 09:53:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050322 Firefox/1.0.2

Description of problem:
If a mail is received in Evolution 2.0.4 (and indeed previous versions) containing a .doc attachment which is an MS Word file then when clicking the down arrow against the attachment at the bottom of the mail, then only the option "Open in OpenOffice.or Writer... " is presented even though Crossover Office is correctly installed and MS Word runs perfectly well.

For some attachments with a .doc extension there is an additional option "Open in Word Processor..."  but never does it associate with MS Word when running in KDE.

The file may be downloaded and opened in Word but not directly from Evolution.

When Evolution runs in Gnome the file assocociations to MS Word running in Crossover Office are present and the attachment may be opened directly in MS Word.

Version-Release number of selected component (if applicable):
evolution-2.0.4-2

How reproducible:
Always

Steps to Reproduce:
1. Go to inbox and select a mail containing a .doc attachment
2 [details]. Go to bottom of mail, and click the down arrow on the right of the attachment icon.
3. View available options to open the file.
  

Actual Results:  See either "Open in OpenOffice.or Writer... " alone or sometimes additionaly "Open in Word Processor..." 

Expected Results:  I would hope that "Open in MS Word.." would have been an option also.

Additional info:

Comment 1 Mike Cohler 2005-04-04 11:49:29 UTC
*** Bug 153270 has been marked as a duplicate of this bug. ***

Comment 2 Mike Cohler 2005-04-04 11:50:12 UTC
*** Bug 153273 has been marked as a duplicate of this bug. ***

Comment 3 Mike Cohler 2005-04-05 09:12:07 UTC
I have discovered a solution.  I was previously using Gnome and from that
desktop Crossover was installed and was running Office 2000.

I swapped to using KDE some months ago, and am now using KDE all the time. This
was the situation when I filed the original bug.

I have last night completely uninstalled Crossover, and then re-installed from
scratch as root, and then as user installed Office XP within Crossover Office. 
I now find that the file associations for .doc files do indeed work and have an
option to open in Word.

It would be nice if there was a simpler and cleaner way to cleanup the file
associations without having to completely re-install Crossover.

Mike




Note You need to log in before you can comment on or make changes to this bug.