Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153265 - apt fails to fetch srclists installed by mirror-select
Summary: apt fails to fetch srclists installed by mirror-select
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: apt
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-04 09:21 UTC by Cipriano Groenendal
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-07 08:33:54 UTC


Attachments (Terms of Use)

Description Cipriano Groenendal 2005-04-04 09:21:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
After running apt-get mirror-select, and selecting one of the mirrors (http://download.fedora.us for example), the mirror-list installs both rpm and rpm-src entries into /etc/apt/sources.list.d/mirror-select.list.
However, when running apt-get update it fails to download the srclist files.
This happens on all mirrors I've tried.

Version-Release number of selected component (if applicable):
apt-0.5.15cnc6-0.fdr.11.2

How reproducible:
Always

Steps to Reproduce:
1) apt-get mirror-select
2) select both Core and Extra
3) select any mirror(13 will do fine;))
4) run apt-get update

Or just run 
echo -e "1,2\nc\n13\nc\n13\nc\n" | apt-get mirror-select && apt-get update

Actual Results:  apt installs rpm-src entries into my sources.list, but they no longer exist.


Expected Results:  It should download all entries.

Additional info:

Hit http://download.fedora.us fedora/2/i386/updates pkglist
Hit http://download.fedora.us fedora/2/i386/updates release
Err http://download.fedora.us fedora/2/i386/os srclist  
  404 Not Found
Err http://download.fedora.us fedora/2/i386/updates srclist
  404 Not Found
Hit http://download.fedora.us fedora/2/i386/stable pkglist
Hit http://download.fedora.us fedora/2/i386/stable release
Hit http://download.fedora.us fedora/2/i386/stable srclist

Comment 1 Michael Schwendt 2005-04-04 11:23:20 UTC
src.rpm packages are no longer provided on download.fedora.us due to disk space
constraints.

Comment 2 Cipriano Groenendal 2005-04-04 11:35:44 UTC
Which is then rsynched by all mirrors.
In that case, someone should edit the mirror-select list that is fetched by apt 
during an apt-get mirror-select, and remove the entries.

Comment 3 Panu Matilainen 2005-04-05 06:52:38 UTC
This is already fixed in the real Extras package, only FC2 apt from fedora.us
times is affected. The problem can't be fixed on server side unfortunately since
mirror-select generates both rpm and rpm-src sources.list entries based on the
base repo location information retrieved from the mirrors list.

Do people still update packages on fedora.us / what the heck should be done with
this?

Comment 4 Warren Togami 2005-04-05 12:30:30 UTC
This is my fault... I totally removed SRPMS from fedora.us.  Should I re-add an
empty directory?  If so which?

Comment 5 Panu Matilainen 2005-04-05 12:53:34 UTC
There should be a matching SRPMS.<component> directory for each component. At
the minumum, SRPMS.os and SRPMS.updates should be created (and repository
metadata updated) to fix the default setup.

Comment 6 Warren Togami 2005-04-07 03:09:04 UTC
Please test now, should be fixed.

Comment 7 Cipriano Groenendal 2005-04-07 08:33:54 UTC
Works fine again, the 404-ing files are now found.

Thanks.

---
Get:5 http://download.fedora.us fedora/2/i386/os srclist 
[14B]                                                              
Get:6 http://download.fedora.us fedora/2/i386/updates srclist 
[14B]                                                         
---



Note You need to log in before you can comment on or make changes to this bug.