Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153251 - rsync segfaults trying to upload
Summary: rsync segfaults trying to upload
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rsync
Version: 3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-04 01:36 UTC by H. Peter Anvin
Modified: 2014-08-31 23:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-04 05:15:13 UTC


Attachments (Terms of Use)

Description H. Peter Anvin 2005-04-04 01:36:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
When trying to upload files using rsync protocol (as opposed to rsync over ssh), rsync-2.6.3-1 segfaults:

Apr  3 18:31:13 zeus2 kernel: rsync[27987]: segfault at 00000000000000a8 rip 0000003cac53f5f5 rsp 0000007fbfffa7a0 error 4
Apr  3 18:31:13 zeus2 kernel: rsync[27988]: segfault at 00000000000000a8 rip 0000003cac53f5f5 rsp 0000007fbfffa7a0 error 4
Apr  3 18:31:13 zeus2 kernel: rsync[27989]: segfault at 00000000000000a8 rip 0000003cac53f5f5 rsp 0000007fbfffa7a0 error 4
Apr  3 18:31:13 zeus2 kernel: rsync[27990]: segfault at 00000000000000a8 rip 0000003cac53f5f5 rsp 0000007fbfffa7a0 error 4


Version-Release number of selected component (if applicable):
rsync-2.6.3-1

How reproducible:
Always

Steps to Reproduce:
1. Set up an upload module in rsyncd.conf and enable it in xinetd
2. Try to sync (I use "rsync -rlHtSq --delete --exclude /mirrors/ --exclude lost+found/ --exclude '.#*' /pub/ korg@${s}::pubupload/" on the client system.)
3. Observe segfault in logs and dropped connection on the client side.

  

Additional info:

The machine, intended to become the new ftp.kernel.org, runs FC3 with current updates as of 2005-04-03.

I have tried to disable "use chroot" per bug 134544; no change in behaviour.

Comment 1 H. Peter Anvin 2005-04-04 04:32:31 UTC
FWIW, upgrading to rsync-2.6.4-2 from rawhide keeps segfaults from showing up in
the syslog, but the connection is still immediately dropped.


Comment 2 H. Peter Anvin 2005-04-04 05:15:13 UTC
It appears rsync was set up to log to a file in a nonexistent directory. 
Creating the directory so the log file could be created solved this problem.

The segfault is still a bug by definition, but 2.6.4-2 at least works.



Note You need to log in before you can comment on or make changes to this bug.