Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153245 - dhclient running multiple times
Summary: dhclient running multiple times
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2005-04-03 23:03 UTC by Florin Andrei
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-28 15:30:52 UTC


Attachments (Terms of Use)

Description Florin Andrei 2005-04-03 23:03:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
AthlonXP system, multiple interfaces, eth0 is on DHCP, the rest are static but disabled.
Sometimes, when booting up, i see this message:

#################################################
Apr  3 15:48:52 demo dhclient: dhclient(1506) is already running - exiting.
Apr  3 15:48:52 demo dhclient:
Apr  3 15:48:52 demo dhclient: If you did not get this software from ftp.isc.org, please
Apr  3 15:48:52 demo dhclient: get the latest from ftp.isc.org and install that before
Apr  3 15:48:52 demo dhclient: requesting help.
Apr  3 15:48:52 demo dhclient:
Apr  3 15:48:52 demo dhclient: If you did get this software from ftp.isc.org and have not
Apr  3 15:48:52 demo dhclient: yet read the README, please read it before requesting help.
Apr  3 15:48:52 demo dhclient: If you intend to request help from the dhcp-server@isc.org
Apr  3 15:48:52 demo dhclient: mailing list, please read the section on the README about
Apr  3 15:48:52 demo dhclient: submitting bug reports and requests for help.
Apr  3 15:48:52 demo dhclient:
Apr  3 15:48:52 demo dhclient: Please do not under any circumstances send requests for
Apr  3 15:48:53 demo dhclient: help directly to the authors of this software - please
Apr  3 15:48:53 demo dhclient: send them to the appropriate mailing list as described in
Apr  3 15:48:53 demo dhclient: the README file.
Apr  3 15:48:53 demo dhclient:
Apr  3 15:48:53 demo dhclient: exiting.
#################################################

Version-Release number of selected component (if applicable):
dhclient-3.0.2-4

How reproducible:
Sometimes

Steps to Reproduce:
1.see above
2.
3.
  

Additional info:

Comment 1 Jason Vas Dias 2005-04-04 13:34:06 UTC
RE:
>Apr  3 15:48:52 demo dhclient: dhclient(1506) is already running -  
exiting.

dhclient only emits this message when it detects that another dhclient
process is running for the SAME interface .

Check that all your /etc/sysconfig/network-scripts/ifcfg-eth* files
that have BOOTPROTO=dhcp have seperate unique DEVICE= settings .




Comment 2 Florin Andrei 2005-04-04 20:00:29 UTC
[root@demo network-scripts]# pwd /etc/sysconfig/network-scripts
[root@demo network-scripts]# for i in `ls ifcfg-*`; do echo
"========"; echo $i; echo "========"; cat $i; echo "========"; echo; done
========
ifcfg-eth0
========
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:90:27:30:9A:DD
ONBOOT=yes
TYPE=Ethernet
DHCP_HOSTNAME=demo.home.local
========

========
ifcfg-eth1
========
DEVICE=eth1
BOOTPROTO=static
HWADDR=00:03:47:08:E2:F1
ONBOOT=no
TYPE=Ethernet
========

========
ifcfg-eth2
========
DEVICE=eth2
BOOTPROTO=static
HWADDR=00:03:47:08:E2:F2
ONBOOT=no
TYPE=Ethernet
========

========
ifcfg-eth3
========
DEVICE=eth3
BOOTPROTO=static
HWADDR=00:11:2F:3B:52:EE
ONBOOT=no
TYPE=Ethernet
========

========
ifcfg-lo
========
DEVICE=lo
IPADDR=127.0.0.1
NETMASK=255.0.0.0
NETWORK=127.0.0.0
# If you're having problems with gated making 127.0.0.0/8 a martian,
# you can change this to something else (255.255.255.255, for example)
BROADCAST=127.255.255.255
ONBOOT=yes
NAME=loopback
========

[root@demo network-scripts]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:90:27:30:9A:DD
          inet addr:192.168.0.176  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1483 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1000 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:137575 (134.3 KiB)  TX bytes:113374 (110.7 KiB)

eth1      Link encap:Ethernet  HWaddr 00:03:47:08:E2:F1
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

eth2      Link encap:Ethernet  HWaddr 00:03:47:08:E2:F2
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

eth3      Link encap:Ethernet  HWaddr 00:11:2F:3B:52:EE
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:11 Base address:0x8000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:341824 errors:0 dropped:0 overruns:0 frame:0
          TX packets:341824 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:28017149 (26.7 MiB)  TX bytes:28017149 (26.7 MiB)


Comment 3 Florin Andrei 2005-04-04 20:05:33 UTC
The system is installed via kickstart.
Here's the relevant part of the ks.cfg:

=========================================
install
cdrom
lang en_US.UTF-8
langsupport --default=en_US.UTF-8 en_US.UTF-8
keyboard us
skipx
text
zerombr yes
network --device eth0 --bootproto dhcp --hostname demo.home.local
network --device eth1 --bootproto static
network --device eth2 --bootproto static
network --device eth3 --bootproto static
rootpw --iscrypted CENSORED :-)
firewall --enabled --port=22:tcp --port=80:tcp --port=443:tcp
--port=21:tcp
selinux --permissive
authconfig --enableshadow --enablemd5
timezone --utc America/Los_Angeles
bootloader --location=mbr --driveorder=hda --append="vga=791 quiet"
clearpart --drives=hda --all
part /boot --fstype ext3 --size=512 --asprimary --ondisk=hda
part / --fstype ext3 --size=10240 --asprimary --ondisk=hda
part swap --size=512 --asprimary --ondisk=hda

%packages
=========================================

Comment 4 Florin Andrei 2005-04-04 20:09:22 UTC
Maybe this is related to bug #153244 ?

Comment 5 Jason Vas Dias 2005-04-28 15:30:52 UTC
Yes, I think this has to do with SELinux issues, which are now fixed 
with the latest selinux-policy-targeted and dhcp-3.0.2-10+ in FC4t3 .

I've been unable to reproduce this problem with the current versions. 



Note You need to log in before you can comment on or make changes to this bug.