Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153219 - Firefox profile locked after reset or crash
Summary: Firefox profile locked after reset or crash
Keywords:
Status: CLOSED DUPLICATE of bug 146900
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-03 09:38 UTC by Jonathan Andrews
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-29 14:25:00 UTC


Attachments (Terms of Use)

Description Jonathan Andrews 2005-04-03 09:38:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Description of problem:
If the machine crashes or is power glitched then the users "profile" in firefox is locked, that user then can not start a new firefox after login without manually finding and removing the lock.

It would be good if the user login could clear any stale locks - it would be even better if the *nix version of firefox stored its state against the user home directory in the standard way rather than adding a poxy and troublesome "profile" system, it was crap in mozilla - its still crap in firefox ! Spoils an otherwise excelent browser.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Login as a user, start firefox
2. Power of the machine by pulling out the mains cable !
[Do not use front panel power switch]

3. Login as a user, start firefox - get "That profile is in use message"
  

Expected Results:  Firefox should start each and every time without ANY questions about "profiles"

Additional info:

Comment 1 Xander D Harkness 2005-04-29 14:25:00 UTC

*** This bug has been marked as a duplicate of 146900 ***


Note You need to log in before you can comment on or make changes to this bug.