Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153213 - %install not honoring %setup -n switch
Summary: %install not honoring %setup -n switch
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 3
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-03 06:55 UTC by Lamont Peterson
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-03 15:29:27 UTC


Attachments (Terms of Use)

Description Lamont Peterson 2005-04-03 06:55:55 UTC
Description of problem: 
When trying to build a package where the pristine source tarball contains a 
single top-level directory whose name does not exactly match 
%{name}-%{version}, it is necessary to use specify: 
 
%setup -n [correct directory name] 
 
Version-Release number of selected component (if applicable): 
rpmbuild 4.3.2 
 
How reproducible: 
Always. 
 
Steps to Reproduce: 
1.  Create a SPEC file to use a source tarball where the name of the directory 
inside the tarball is not %{name}-%{version}, using the -n switch to the 
%setup macro 
2.  Run "rpmbuild -ba some.spec" 
3.  When rpmbuild tries to run "make [lotsa-dir-options] install", it fails 
because it is in the %{_builddir} directory 
 
Actual results: 
Failed build 
 
Expected results: 
Packages should be built 
 
Additional info: 
I have tested this on both i386 (Athlon-XP, Pentium 4) and x86_64 (2x Opteron 
242), same problem.  I have only tested this with one SPEC file.

Comment 1 Lamont Peterson 2005-04-03 15:29:27 UTC
This morning, I found a small typo in the SPEC file responsible for this   
"bug".  That's what I get for trying to file a bug so late at night.  
  
Just in case, I also tried a simple test case SPEC file; it works fine.  So, 
please close this one out.  Thanks. 


Note You need to log in before you can comment on or make changes to this bug.