Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153210 - volume applet does not start
Summary: volume applet does not start
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-03 05:21 UTC by Sean Bruno
Modified: 2013-03-13 04:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-23 18:33:27 UTC


Attachments (Terms of Use)

Description Sean Bruno 2005-04-03 05:21:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Firefox/1.0.2 Fedora/1.0.2-3

Description of problem:
On login, or attempt to start the volume control applet you receive an error window with the following information:

Registry is not present or it is corrupted, please update it by running gst-register


I attempted to run gst-register and recieved the following output:

[sean@localhost ~]$ /usr/bin/gst-register
Trying to load global_registry ...
Error loading global_registry
Added path   /usr/lib/gstreamer-0.8 to user_registry
Rebuilding user_registry (/home/sean/.gstreamer-0.8/registry-i386.xml) ...
Added plugin stereo with 1 feature.
...  more stuff
Added plugin gstbasicomegascheduler with 1 feature.
Added plugin vbidec with 1 feature.
/usr/bin/gst-register: line 3:  4296 Segmentation fault      $x


Running the gst-register binary in /usr/libexec/gst-register-i386-0.8
yeilds the same output, but attaching GDB to it is useless as all debug symbols have been stripped.



Version-Release number of selected component (if applicable):
gstreamer-tools-0.8.9-4

How reproducible:
Always

Steps to Reproduce:
1.  Attempt to start the volume control applet.

  

Actual Results:  Error window popped up

Expected Results:  Volume control applet should have started and appeared in notification area.

Additional info:

I have two audio devices in my machine:

USB Headset:
Bus 003 Device 002: ID 047f:0ca1 Plantronics, Inc.

Onboard PCI:
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)

Comment 1 Sean Bruno 2005-04-05 06:29:38 UTC
At the suggestion of one of the folks on the fedora-test list, I installed the
debuginfo RPM for gstreamer.  I got some more information, but not much:

Added plugin vbidec with 1 feature.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208842560 (LWP 5983)]
0x00000000 in ?? ()
(gdb) where
#0  0x00000000 in ?? ()
#1  0x00af88d5 in pthread_once () from /lib/tls/libpthread.so.0
#2  0x03678d8e in glXChannelRectSyncSGIX () from /usr/lib/libGL.so.1
#3  0x036aa1f8 in ?? () from /usr/lib/libGL.so.1
#4  0x036790fc in _init () from /usr/lib/libGL.so.1
#5  0x00000000 in ?? ()


Don't know if this helps, but I will try to keep poking at it.

Comment 2 Sean Bruno 2005-04-06 06:48:35 UTC
Nicely done to whomever traced this bug out.  I updated to rawhide and the core
dump is no longer occuring.  I am still seeing an error window pop-up thought
when I attempt to start the volume control applet.  Window contents:

No volume control elements and/or devices found



Comment 3 Sean Bruno 2005-04-07 22:15:51 UTC
Looks like this issue is now resolved.  I rebooted after updating today(didn't
reboot yesterday), and I have a sound volume applet again.  Nice work!

Comment 4 Sean Bruno 2005-04-07 22:16:19 UTC
I'll let u close this one.

Comment 5 John (J5) Palmieri 2005-04-14 20:35:33 UTC
Not really fixed.  I still see it happening in test2.  I'll need to debug further 

Comment 6 Sean Bruno 2005-04-15 23:37:18 UTC
Uh, I don't see this happening on my machine.  I have a volume applet and all
looks normal.

Comment 7 John (J5) Palmieri 2005-04-16 17:30:59 UTC
Actually it happens when I created a new account.  My main account works fine. 
I think it is somewhat random which will make it harder to debug.

Comment 8 Sean Bruno 2005-05-23 18:33:27 UTC
This issue seems to have gone away.  I am marking it as NOTABUG.

Comment 9 Shawn N 2005-06-23 06:53:49 UTC
I am seeing the same issue in FC4 final.  Volume control applet will not start
and  running gst-register segfaults.  A complete removeal of the gstreamer rpms
and reinstall yeilds  the same result.

Comment 10 Shawn N 2005-06-23 07:06:00 UTC
Quick follow up.  In my case it appears that removing libgstglimagesink.so fixes
the segfault.

Comment 11 Sean Bruno 2005-06-23 15:51:14 UTC
This is NOT happening to my machines with FC4 final.  You may have something
else going on.  As this issue is closed(for me at least), you may have better
luck opening a new report.  List ur hardware in the ticket also.


Note You need to log in before you can comment on or make changes to this bug.