Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153205 - perl-URI: update and specfile cleanup
Summary: perl-URI: update and specfile cleanup
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-URI
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact:
URL:
Whiteboard:
: 140932 141101 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-02 21:10 UTC by Jose Pedro Oliveira
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-03 05:35:39 UTC


Attachments (Terms of Use)
Update and specfile cleanup (deleted)
2005-04-02 21:10 UTC, Jose Pedro Oliveira
no flags Details | Diff

Description Jose Pedro Oliveira 2005-04-02 21:10:53 UTC
Version-Release number of selected component (if applicable):
1.30

Comment 1 Jose Pedro Oliveira 2005-04-02 21:10:54 UTC
Created attachment 112632 [details]
Update and specfile cleanup

Comment 2 Warren Togami 2005-04-02 22:31:53 UTC
*** Bug 140932 has been marked as a duplicate of this bug. ***

Comment 3 Warren Togami 2005-04-02 22:32:47 UTC
*** Bug 141101 has been marked as a duplicate of this bug. ***

Comment 4 Jose Pedro Oliveira 2005-04-03 03:09:56 UTC
Warren,

Didn't test the filter correctly: perl(Business::ISBN) shouldn't appear
in the requirements (rpm -qpR ...).

Please apply the followin patch to the specfile:

-%define __find_requires %{SOURCE1}
+%define __perl_requires %{SOURCE1}

Comment 5 Warren Togami 2005-04-03 05:35:39 UTC
What is the difference between __find_requires and __perl_requires? Applying...

Comment 6 Ville Skyttä 2005-04-03 11:31:54 UTC
I think "%define __find_requires ..." is a noop unless one also does "%define
_use_internal_dependency_generator 0".


Note You need to log in before you can comment on or make changes to this bug.