Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153202 - startkde gets wrong field from space_tmp with finnish and some other languages too
Summary: startkde gets wrong field from space_tmp with finnish and some other language...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase
Version: 2
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-02 19:50 UTC by Ilpo Kantonen
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-05-13 22:40:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 103094 None None None Never

Description Ilpo Kantonen 2005-04-02 19:50:36 UTC
Description of problem:   
   
In script /usr/bin/starkde I found lines    
   
    space_tmp=`df /tmp | xargs | cut -d" " -f11`    
    homedir_mount=`df "$HOME" | xargs | cut -d" " -f8`    
   
 and then they are called in same script:    
    
 if [ $space_tmp -lt 50 ]; then     <- line 24    
 ...    
 if [ $space_home -lt 25 ]; then   <- line 29    
    
 and that causes error lines in .xession-errors file in home directory:    
    
 /usr/bin/startkde: line 24: [: 6%: integer expression expected    
 /usr/bin/startkde: line 29: [: 40%: integer expression expected    
    
 I tried to execute space_tmp manually and that returned just 6%. Not an integer!    
 That occurred in Fedora Core 2 system and Ubuntu. Slackware linux works ok.    
   
   
Version-Release number of selected component (if applicable):   
Fedora Core 2, kernel 2.6.10-1.771_FC2  
   
How reproducible:   
I tried manually  df /tmp | xargs | cut -d" " -f11 and it occurred every time.  
   
Steps to Reproduce:   
1.  df /tmp | xargs | cut -d" " -f11  
2.   
3.   
     
Actual results:   
 6% on my system just now.  
   
Expected results:   
integer value   
   
Additional info:  
Seems to be that startkde script matches wrong field with -f11 or -f8 with finnish 
language fedora and some other languages too.  Coud be better if there is not such 
assumptions of field places and orders.

Comment 1 Matthew Miller 2005-04-26 15:03:57 UTC
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.

Comment 2 Ngo Than 2006-05-13 22:40:25 UTC
it's now fixed in our CVS. I will build new kdebase including this fix in
FC5 update and rawhide soon. Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.