Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153197 - /sbin/ldconfig not run with --oldpackage
Summary: /sbin/ldconfig not run with --oldpackage
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-02 18:03 UTC by Gene Czarcinski
Modified: 2008-10-23 04:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-04-24 23:02:55 UTC


Attachments (Terms of Use)

Description Gene Czarcinski 2005-04-02 18:03:22 UTC
Description of problem:
When I read the message which explained that sshd was having I problem with
openssl-0.9.7f-1 and to simply back off to openssl-0.9.7e-3, I thought I would
give it a try.

I was surprised when lots of things stopped working because libssl.so.5 did not
exist.  I tracked the problem down to the fact that installing openssl-0.9.7e-3
with --oldpackage had resulted in the sym-links not being updated.  When I
finally did install openssl-0.9.7f-3 the sym-links were updated.

Version-Release number of selected component (if applicable):
rpm 4.4.1-9, openssl 0.9.7f-3 and openssl 0.9.7e-3

How reproducible:
yes.

Steps to Reproduce:
1. update to "current" openssl in development
2. then rpm -Uvh --oldpackage from FC4T1 initial distribution
3. ls -l /lib/libssl* /lib/libcrypto* /lib64/libssl* /lib64/libcrypto*
  
Actual results:
hanging sym-links for libssl.so.5 and libcrypto.so.5

Expected results:
symlinks updated to point to currently installed libraries

Additional info:

I believe this is an rpm problem but it also could be a packaging problem with
openssl.

The system used was x86_64 although I expect it to be the same on a i386 system.

Comment 1 Jeff Johnson 2006-04-24 23:02:55 UTC
RPM does not support downgrades as with --oldpackage.

Comment 2 Matt McCutchen 2008-10-23 04:38:34 UTC
I just hit the same problem downgrading my glib2 from rawhide back to Fedora 9 after I finished testing a program that needed the rawhide version.  When I logged out of GNOME, gdm died and I had to run ldconfig manually from the terminal.

What is the purpose of --oldpackage if not for downgrades?  It seems to me that the problem could be fixed easily by letting ldconfig run a second time after the erasures are complete.  I understand that the symlinks will still be broken during the erasures (the only way to fix that would be for rpm to somehow indicate its planned shared library deletions to ldconfig before actually performing them), but that's better than leaving them broken forever.


Note You need to log in before you can comment on or make changes to this bug.