Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153181 - screen blank but machine live after resume
Summary: screen blank but machine live after resume
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-02 05:18 UTC by Joe Harrington
Modified: 2015-01-04 22:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-15 18:51:13 UTC


Attachments (Terms of Use)

Description Joe Harrington 2005-04-02 05:18:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Galeon/1.3.20

Description of problem:
Sometimes when after a resume, the screen is blank.  I can login on the ethernet and the machine otherwise functions fine.  This is not the "blinking caps-lock bug".  Nothing I type goes to a window, and the mouse pointer is not visible.  If I ctrl-alt-del, the screen becomes alive, and I see my windows go away, revealing my background, which refreshes fine until it, too goes away.  Then X is back with a login screen.

This happens about every 2 weeks.  I suspend about 2-4x/day, usually for 1-4 hours.

Thinkpad T40, APM suspend (ACPI has no automatic suspend for low battery and the 
warning programs for low battery only warn once).  Started happening in FC3, and has persisted through all updates.  I have xorg-x11-6.8.2-1.FC3.13.  Did not happen in FC1.




Version-Release number of selected component (if applicable):
kernel-2.6.10-1.770_FC3

How reproducible:
Sometimes

Steps to Reproduce:
1.suspend and resume a lot
2.will happen eventually
3.
  

Actual Results:  Screen blank, no mouse pointer.  After C-A-BS, screen goes live and I can watch shutdown activities.

Expected Results:  Screen live.

Additional info:

I'm marking this high severity since I lose my running programs and their data when I kill X to get out of the problem.

--jh--

Comment 1 Joe Harrington 2005-04-02 05:22:54 UTC
Sorry about the super-long lines above.  I just typed into a browser typein box
and submitted...

--jh--

Comment 2 Dave Jones 2005-07-15 18:34:30 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 3 Joe Harrington 2005-07-15 18:51:13 UTC
Actually, this one appears to have been fixed a few kernels ago.  I haven't seen
it in a few months.  Thanks for fixing!  I'm marking this resolved in errata.

--jh--


Note You need to log in before you can comment on or make changes to this bug.