Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153180 - No print status icon appears in notifcation area on print
Summary: No print status icon appears in notifcation area on print
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: desktop-printing
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
: 154937 (view as bug list)
Depends On:
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2005-04-02 05:18 UTC by Sean Bruno
Modified: 2013-03-06 03:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-21 12:07:49 UTC


Attachments (Terms of Use)
patch to allow cups to send dbus messages to users (deleted)
2005-04-15 18:32 UTC, Colin Walters
no flags Details | Diff

Description Sean Bruno 2005-04-02 05:18:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Firefox/1.0.2 Fedora/1.0.2-3

Description of problem:
Under FC3 an icon would appear in the notification area when a print job was submitted.  FC4T1 fully updated to rawhide does not display this behaviour.  There appears to be no way to access the print queue in a graphical sense in FC4T1 as well.

Version-Release number of selected component (if applicable):
cups-1.1.23-15

How reproducible:
Always

Steps to Reproduce:
1.  Submit a print job from evolution, firefox or openoffice(print something).
  

Actual Results:  Print job succeeded, but there was no print status icon in the notification area.

Expected Results:  Print job should succeed, but there should be a print status icon in the notification area.

Additional info:

All cups related packages.  output from rpm -q -a|grep cups:

libgnomecups-devel-0.2.0-1
cups-1.1.23-15
cups-devel-1.1.23-15
hal-cups-utils-0.5.3-3
bluez-utils-cups-2.15-5
libgnomecups-0.2.0-1
cups-lpd-1.1.23-15
gimp-print-cups-4.2.7-5
cups-libs-1.1.23-15

Comment 1 Sean Bruno 2005-04-06 06:54:50 UTC
still an issue today.

Comment 2 Sean Bruno 2005-04-07 22:17:13 UTC
yep...still happening, this kind of hurts here as there is no way to stop a
print job graphically right now.

Comment 3 Sean Bruno 2005-04-08 20:49:11 UTC
Today's updates had no impact.  Still an issue

Comment 4 Ray Strode [halfline] 2005-04-14 20:27:33 UTC
Hey John,
You fixed this yea?

Comment 5 John (J5) Palmieri 2005-04-14 20:34:35 UTC
should be in rawhide tomorrow

Comment 6 Deji 2005-04-15 18:13:11 UTC
Still no print status applet after updating to today's rawhide. Although it
might be due to this;

Apr 15 12:46:02 rhema2 dbus: avc:  denied  { send_msg } for msgtype=signal
interface=com.redhat.PrinterSpooler member=QueueChanged
dest=org.freedesktop.DBus spid=1997 tpid=2840 scontext=user_u:system_r:cupsd_t
tcontext=user_u:system_r:unconfined_t tclass=dbus 
Apr 15 12:46:02 rhema2 dbus: avc:  denied  { send_msg } for msgtype=signal
interface=com.redhat.PrinterSpooler member=QueueChanged
dest=org.freedesktop.DBus spid=1997 tpid=2931 scontext=user_u:system_r:cupsd_t
tcontext=user_u:system_r:unconfined_t tclass=dbus 
Apr 15 12:46:02 rhema2 dbus: avc:  denied  { send_msg } for msgtype=signal
interface=com.redhat.PrinterSpooler member=JobQueuedLocal
dest=org.freedesktop.DBus spid=1997 tpid=2840 scontext=user_u:system_r:cupsd_t
tcontext=user_u:system_r:unconfined_t tclass=dbus 
Apr 15 12:46:02 rhema2 dbus: avc:  denied  { send_msg } for msgtype=signal
interface=com.redhat.PrinterSpooler member=JobQueuedLocal
dest=org.freedesktop.DBus spid=1997 tpid=2931 scontext=user_u:system_r:cupsd_t
tcontext=user_u:system_r:unconfined_t tclass=dbus 
Apr 15 12:46:02 rhema2 dbus: avc:  denied  { send_msg } for msgtype=signal
interface=com.redhat.PrinterSpooler member=JobStartedLocal
dest=org.freedesktop.DBus spid=1997 tpid=2840 scontext=user_u:system_r:cupsd_t
tcontext=user_u:system_r:unconfined_t tclass=dbus 
Apr 15 12:46:02 rhema2 dbus: avc:  denied  { send_msg } for msgtype=signal
interface=com.redhat.PrinterSpooler member=JobStartedLocal
dest=org.freedesktop.DBus spid=1997 tpid=2931 scontext=user_u:system_r:cupsd_t
tcontext=user_u:system_r:unconfined_t tclass=dbus 
Apr 15 13:01:01 rhema2 crond(pam_unix)[2970]: session opened for user root by
(uid=0)
Apr 15 13:01:02 rhema2 crond(pam_unix)[2970]: session closed for user root
Apr 15 13:34:24 rhema2 dbus: avc:  denied  { send_msg } for msgtype=signal
interface=com.redhat.PrinterSpooler member=QueueChanged
dest=org.freedesktop.DBus spid=1997 tpid=2840 scontext=user_u:system_r:cupsd_t
tcontext=user_u:system_r:unconfined_t tclass=dbus 
Apr 15 13:34:24 rhema2 dbus: avc:  denied  { send_msg } for msgtype=signal
interface=com.redhat.PrinterSpooler member=QueueChanged
dest=org.freedesktop.DBus spid=1997 tpid=2931 scontext=user_u:system_r:cupsd_t
tcontext=user_u:system_r:unconfined_t tclass=dbus 

Comment 7 Colin Walters 2005-04-15 18:20:32 UTC
Dan, looks like policy needs to be fixed.

Comment 8 Colin Walters 2005-04-15 18:32:32 UTC
Created attachment 113242 [details]
patch to allow cups to send dbus messages to users

Something like this (untested).

Comment 9 Daniel Walsh 2005-04-15 18:39:11 UTC
I wonder if a cleaner solution would be to put unconfined_t in the
userdomain/unpriv_userdomain?  Although this could be dangerous.

Comment 10 Sean Bruno 2005-04-22 15:57:12 UTC
nice work...seems to work for me now under FC4T2

Comment 11 Ray Strode [halfline] 2005-04-25 19:10:57 UTC
*** Bug 154937 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.