Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153178 - perl-BSD-Resource: specfile update
Summary: perl-BSD-Resource: specfile update
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-BSD-Resource
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-02 01:33 UTC by Jose Pedro Oliveira
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-09 07:54:28 UTC


Attachments (Terms of Use)
Specfile cleanup (deleted)
2005-04-02 01:33 UTC, Jose Pedro Oliveira
no flags Details | Diff

Description Jose Pedro Oliveira 2005-04-02 01:33:00 UTC
Description of problem:
Specfile update (using Fedora.Extras template).

Version-Release number of selected component (if applicable):
1.24-1

Comment 1 Jose Pedro Oliveira 2005-04-02 01:33:00 UTC
Created attachment 112608 [details]
Specfile cleanup

Comment 2 Warren Togami 2005-04-02 02:01:56 UTC
odd...

+ make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0,
'blib/lib', 'blib/arch')" t/*.t
t/getpriority....ok
t/getrlimit......ok
t/getrusage......ok
t/setpriority....ok
t/setrlimit......Use of uninitialized value in concatenation (.) or string at
t/setrlimit.t line 44.
Use of uninitialized value in numeric eq (==) at t/setrlimit.t line 45.
FAILED test 14
        Failed 1/14 tests, 92.86% okay
t/times..........ok
Failed 1/6 test scripts, 83.33% okay. 1/39 subtests failed, 97.44% okay.
Failed Test   Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
t/setrlimit.t               14    1   7.14%  14
make: *** [test_dynamic] Error 255
error: Bad exit status from /usr/src/build/549719-ppc/install-tmp/rpm-tmp.86827
(%check)


Comment 3 Warren Togami 2005-04-02 02:06:10 UTC
failure on i386 too... something might be different about the beehive buildroot

Comment 4 Jose Pedro Oliveira 2005-04-02 02:17:04 UTC
I have no problems building perl-BSD-Resource with both specfiles (releases 1
and 2) in Fedora Core 3 systems.
  ...
  t/getpriority....ok
  t/getrlimit......ok
  t/getrusage......ok
  t/setpriority....ok
  t/setrlimit......ok
  t/times..........ok
  All tests successful.
  ...

Also note that the old specfile (release 1) executed the tests with the
following command:
   make test || /bin/true

Comment 5 Warren Togami 2005-04-02 02:34:28 UTC
This may be indicative of something else being broken in FC4.  Have you tried
mach+yum?  It will easily allow you to build FC4 packages on your FC3 machine.

http://cvs.fedora.redhat.com/viewcvs/extras-buildsys-temp/?root=fedora
Check out, make a tarball and rpmbuild -ta, then install it


Comment 6 Warren Togami 2005-04-02 03:02:17 UTC
Build succeeded without that test failure on my x86_64 everything install. 
Could this be a missing BuildReq?


Comment 7 Warren Togami 2005-04-02 03:55:20 UTC
(BTW I didn't include the part of your patch that added %doc.  The license does
not require adding docs and we're in trouble right now limiting the size of FC.
Every bit counts...)

Comment 8 Michael Schwendt 2005-04-03 08:07:32 UTC
[mach+yum builds this without problems on a moderately updated FC4T1]

setrlimit is a glibc function, accessed from the Perl test via a C wrapper
function in Resource.pm -> Resource.o. The Perl function returns 'undef' on
failure, which explains the results in the test. Does beehive impose any special
kinds of resource limits?

Comment 9 Warren Togami 2005-04-09 07:54:28 UTC
No time to test, skipped test. 

Comment 10 Jose Pedro Oliveira 2005-04-13 15:15:44 UTC
Warren,

No problems rebuilding perl-BSD-Resource in a FC4test2 system with the
test suite enabled. 

The problem must be in the building system (see also comment #8).

Comment 11 Neil Horman 2007-08-22 11:56:18 UTC
*** Bug 251101 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.