Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153170 - sata_sil missing PCI IDs for ATI SATA controller
Summary: sata_sil missing PCI IDs for ATI SATA controller
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-01 22:48 UTC by wingc
Modified: 2015-01-04 22:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-27 03:15:02 UTC


Attachments (Terms of Use)

Description wingc 2005-04-01 22:48:14 UTC
This is a copy of bug #152627. The problem still exists in the latest RHEL4
errata kernel (2.6.9-5.0.3.EL)


The PCI IDs for the ATI IGP integrated SATA controller need to be added to
drivers/scsi/sata_sil.c and the boot loader image needs to be updated so the
installer recognizes this hardware.

The PCI IDs in question are:
0x1002  0x436e  "sata_sil"      "ATI|IXP300 SATA"
0x1002  0x4379  "sata_sil"      "ATI|IXP400 SATA"

The linux-2.6 changeset in question is:
http://linus.bkbits.net:8080/linux-2.5/cset@41e4b5df5jSP3VOlsSO6pnMqEBX79A


I confirmed that the RHEL4 kernel works properly once these PCI IDs are added to
drivers/scsi/sata_sil.c. I followed the same procedure as I described in bug
#152627; recompiling the driver and creating a driver update disk to use with
Anaconda. Everything worked properly.


Sorry, I couldn't see any channel for RHEL4 beta packages when I log into the
Red Hat network page. Otherwise I would have tried taking a look to see if this
has already been committed for future RHEL4 updates.

Comment 1 Jay Turner 2005-04-04 08:59:53 UTC
IDs confirmed in kernel-2.6.9-6.37.EL (U1-candidate kernel)


Note You need to log in before you can comment on or make changes to this bug.