Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1531495 - Readiness probe failed when use crio
Summary: Readiness probe failed when use crio
Keywords:
Status: CLOSED DUPLICATE of bug 1517652
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Hawkular
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.9.0
Assignee: Matt Wringe
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-05 10:19 UTC by Anping Li
Modified: 2018-01-10 03:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-05 14:26:22 UTC


Attachments (Terms of Use)

Description Anping Li 2018-01-05 10:19:26 UTC
Description of problem:
The cassandra coundn't started for Readiness probe failed: Could not get the Cassandra status. This may mean that the Cassandra instance is not up yet.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install OCP 3.9 use crio
2. Deploy metrics
3. Check the pods status

Actual results:

#oc get pods
[root@ip-172-18-7-88 ~]# oc get pods
NAME                         READY     STATUS    RESTARTS   AGE
hawkular-cassandra-1-bmpm5   0/1       Running   0          12m
hawkular-metrics-qqndj       0/1       Running   1          12m
heapster-fxpsb               0/1       Running   1          12m


#oc describe pod hawkular-cassandra-1-bmpm5
Tolerations:     <none>
Events:
  Type     Reason                 Age               From                                   Message
  ----     ------                 ----              ----                                   -------
  Normal   Scheduled              7m                default-scheduler                      Successfully assigned hawkular-cassandra-1-bmpm5 to ip-172-18-1-228.ec2.internal
  Normal   SuccessfulMountVolume  7m                kubelet, ip-172-18-1-228.ec2.internal  MountVolume.SetUp succeeded for volume "cassandra-data"
  Normal   SuccessfulMountVolume  7m                kubelet, ip-172-18-1-228.ec2.internal  MountVolume.SetUp succeeded for volume "cassandra-token-x5tjl"
  Normal   SuccessfulMountVolume  7m                kubelet, ip-172-18-1-228.ec2.internal  MountVolume.SetUp succeeded for volume "hawkular-cassandra-certs"
  Normal   Pulled                 7m                kubelet, ip-172-18-1-228.ec2.internal  Container image "registry.reg-aws.openshift.com:443/openshift3/metrics-cassandra:v3.9" already present on machine
  Normal   Created                7m                kubelet, ip-172-18-1-228.ec2.internal  Created container
  Normal   Started                7m                kubelet, ip-172-18-1-228.ec2.internal  Started container
  Warning  Unhealthy              2m (x30 over 7m)  kubelet, ip-172-18-1-228.ec2.internal  Readiness probe failed: Could not get the Cassandra status. This may mean that the Cassandra instance is not up yet. Will try again
/opt/apache-cassandra/bin/cassandra-docker-ready.sh: line 25: nodetool: command not found



Expected results:


Additional info:
#oc exec hawkular-cassandra-1-bmpm5 -- /opt/apache-cassandra/bin/cassandra-docker-ready.sh
Picked up JAVA_TOOL_OPTIONS: -Duser.home=/home/jboss -Duser.name=jboss
Cassandra is in the up and normal state. It is now ready.

Comment 1 Matt Wringe 2018-01-05 14:26:22 UTC

*** This bug has been marked as a duplicate of bug 1517652 ***


Note You need to log in before you can comment on or make changes to this bug.