Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153102 - redhat-config-nfs requires X on the machine
Summary: redhat-config-nfs requires X on the machine
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora Legacy
Classification: Retired
Component: redhat-config-nfs
Version: rhl9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Fedora Legacy Bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-01 15:51 UTC by Nigel Horne
Modified: 2007-04-18 17:22 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-01 16:37:11 UTC


Attachments (Terms of Use)

Description Nigel Horne 2005-04-01 15:51:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
I have an old machine without X, but redhat-config-nfs doesn't run. It gives this gobbledegook message instead which I take to mean in English that it must have X installed to run.

Traceback (most recent call last):
  File "/usr/share/redhat-config-nfs/redhat-config-nfs.py", line 23, in ?
    import mainWindow
  File "/usr/share/redhat-config-nfs/mainWindow.py", line 21, in ?
    import nfsBackend
  File "/usr/share/redhat-config-nfs/nfsBackend.py", line 23, in ?
    import gtk
  File "/usr/src/build/147273-i386/install/usr/lib/python2.2/site-packages/gtk/__init__.py", line 19, in ?
RuntimeError: could not open display


Version-Release number of selected component (if applicable):
redhat-config-nfs-1.0.1-3

How reproducible:
Always

Steps to Reproduce:
1. ssh to a machine without X
2. try redhat-config-nfs
3.
  

Actual Results:  raceback (most recent call last):
  File "/usr/share/redhat-config-nfs/redhat-config-nfs.py", line 23, in ?
    import mainWindow
  File "/usr/share/redhat-config-nfs/mainWindow.py", line 21, in ?
    import nfsBackend
  File "/usr/share/redhat-config-nfs/nfsBackend.py", line 23, in ?
    import gtk
  File "/usr/src/build/147273-i386/install/usr/lib/python2.2/site-packages/gtk/__init__.py", line 19, in ?
RuntimeError: could not open display


Expected Results:  I should have been able to configure the NFS server.

Additional info:

Comment 1 Jesse Keating 2005-04-01 16:37:11 UTC
This is by design.  There is no tui component to redhat-config-nfs.  If you have
the X-libs installed, and ssh to the system w/ X forwarding, you can run the
application on a remote X server.


Note You need to log in before you can comment on or make changes to this bug.