Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153096 - NM goes down faster than your mom
Summary: NM goes down faster than your mom
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-01 15:16 UTC by Bryan W Clark
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-07 15:49:20 UTC


Attachments (Terms of Use)

Description Bryan W Clark 2005-04-01 15:16:36 UTC
It does it's job for a while and then I've just noticed that NMI will disappear
so I ran NM in gdb and caught this.  It's pretty reproduceable, just takes some
time to happen again.

Here's some backtrace stuff:

NetworkManager: <information>   Restarting mDNSResponder.
NetworkManager: <information>   Activation (eth0/wireless): Success!  Connected
to access point 'Eric The Red' and got an IP address.
NetworkManager: <information>   Activation (eth0) IP configuration/DHCP successful!
NetworkManager: <information>   Activation (eth0) ended.
NetworkManager: <information>   Activation (eth0) successful, device activated.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208047040 (LWP 15232)]
0x00000000 in ?? ()
(gdb) bt
#0  0x00000000 in ?? ()
#1  0x00d9e9f1 in libhal_psi_get_strlist () from /usr/lib/libhal.so.1
#2  0x05e5315a in dbus_connection_dispatch () from /usr/lib/libdbus-1.so.1
#3  0x0087b21e in dbus_g_pending_call_cancel ()
   from /usr/lib/libdbus-glib-1.so.1
#4  0x00b25d4c in g_io_unix_dispatch (source=0x97bee80, callback=0,
    user_data=0x97c1c00) at giounix.c:162
#5  0x00b0046e in IA__g_main_context_dispatch (context=0x97bc590)
    at gmain.c:1947
#6  0x00b03476 in g_main_context_iterate (context=0x97bc590, block=1,
    dispatch=1, self=0x97ba608) at gmain.c:2578
#7  0x00b03763 in IA__g_main_loop_run (loop=0x97bbf78) at gmain.c:2782
#8  0x0805ab87 in main (argc=2, argv=0xbfee9a64) at NetworkManager.c:910
(gdb) list
910             g_main_loop_run (nm_data->main_loop);
911
912             /* Cleanup */
913             libhal_ctx_shutdown (nm_data->hal_ctx, &dbus_error);
914
915             if (dbus_error_is_set (&dbus_error)) {
916                     nm_warning ("libhal shutdown failed - %s",
917                                 dbus_error.message);
918                     dbus_error_free (&dbus_error);
919             }

Comment 1 Dan Williams 2005-04-01 15:25:01 UTC
Dude, your mom is the one who holds the current speed record, not mine.  I can
attest to that.

Comment 2 Dan Williams 2005-05-05 19:28:13 UTC
hmm, does this still happen?

Comment 3 Bryan W Clark 2005-05-05 19:32:14 UTC
It still crashes, I can try to get a more recent backtrace of a crash. 

Comment 4 Bryan W Clark 2005-05-05 19:37:45 UTC
I think the main problem is bug 120472 right now, NM only seems to crash when
I'm on a wired connection and then nothing really changes except that I don't
see the icon anymore. 

Comment 5 Bryan W Clark 2005-05-07 15:49:20 UTC
Closing this since I've jumped versions and haven't seen this problem in a while.


Note You need to log in before you can comment on or make changes to this bug.