Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153093 - boost warns that gcc 4.0.0 is an unknown compiler
Summary: boost warns that gcc 4.0.0 is an unknown compiler
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: boost
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Benjamin Kosnik
QA Contact:
URL:
Whiteboard:
: 157769 (view as bug list)
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-04-01 14:52 UTC by Caolan McNamara
Modified: 2013-08-09 05:47 UTC (History)
3 users (show)

Fixed In Version: 1.32
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-13 20:01:10 UTC


Attachments (Terms of Use)
gcc-4.x boost patch (deleted)
2005-04-01 18:45 UTC, Benjamin Kosnik
no flags Details | Diff

Description Caolan McNamara 2005-04-01 14:52:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050330

Description of problem:
boost headers warn that it doesn't know about gcc 4.0.0

Version-Release number of selected component (if applicable):
boost-1.32.0-3

How reproducible:
Always

Steps to Reproduce:
1. compile somethat that uses boost

Actual Results:  /usr/include/boost/compiler/gcc.hpp:92:7 : warning: #warning "Unknown compiler version - please run the configure tests and report the results"

Expected Results:  no warning

Additional info:

it's purely cosmetic as it works fine

Comment 1 Benjamin Kosnik 2005-04-01 18:44:37 UTC
I'm assuming this is with boost-1.32.0-5.

Fixing this is not hard: I've attached the patch.

I'm having problems building 1.32.0 with gcc-4.0 which have kept this
patch out of the boost rpms. Although what you are doing may be working,
rebuilding all of boost with gcc-4.0 is not. Use this patch with care.


Comment 2 Benjamin Kosnik 2005-04-01 18:45:46 UTC
Created attachment 112595 [details]
gcc-4.x boost patch


Does not allow full gcc-4 rebuild of the src rpm.

Comment 3 Avi Kivity 2005-05-15 09:43:50 UTC
some people (me) like to use -Werror when compiling; this is a blocker for    
them.   
 

Comment 4 Avi Kivity 2005-05-16 11:26:29 UTC
I've rebuilt the package, with the patch, on gcc-4.0.0-5 (x86_64), so it appears
the problem has been fixed. can we get a gcc4 happy boost for fc4?

Comment 6 Benjamin Kosnik 2005-05-24 15:15:12 UTC
*** Bug 157769 has been marked as a duplicate of this bug. ***

Comment 7 Benjamin Kosnik 2005-05-24 16:53:02 UTC
Fixed in boost-1.32.0-6.

Comment 8 Avi Kivity 2005-05-29 06:40:40 UTC
verified. 


Note You need to log in before you can comment on or make changes to this bug.