Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153053 - GtkDeprecationWarning: gtk.FALSE, gtk.TRUE
Summary: GtkDeprecationWarning: gtk.FALSE, gtk.TRUE
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-soundcard
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-01 04:31 UTC by Ricky Ng-Adam
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.2.11-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-09 11:09:14 UTC


Attachments (Terms of Use)
fixes the warnings (deleted)
2005-04-01 04:48 UTC, Colin Charles
no flags Details | Diff

Description Ricky Ng-Adam 2005-04-01 04:31:32 UTC
Description of problem:

/usr/share/system-config-soundcard/soundcard.py:75: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  self.box = gtk.VBox(gtk.FALSE, 8)
/usr/share/system-config-soundcard/soundcard.py:139: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  self.notebook.set_show_tabs(gtk.FALSE)
/usr/share/system-config-soundcard/soundcard.py:140: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  self.notebook.set_show_border(gtk.FALSE)
/usr/share/system-config-soundcard/soundcard.py:303: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  self.icon_box.pack_start(self.icon, gtk.FALSE)
/usr/share/system-config-soundcard/soundcard.py:304: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  self.icon_box.pack_start(self.label, gtk.FALSE)
/usr/share/system-config-soundcard/soundcard.py:305: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  self.toplevel.pack_start(self.icon_box, gtk.FALSE)
/usr/share/system-config-soundcard/soundcard.py:307: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  self.toplevel.pack_start(self.box, gtk.FALSE)


Version-Release number of selected component (if applicable):

1.2.10-3

How reproducible:

always

Steps to Reproduce:
1. start program at console
2.
3.
  
Actual results:

extraneous warnings

Expected results:

no warnings

Additional info:

Most system-config-* have the same problems, I'm opening a bug for each.

Comment 1 Colin Charles 2005-04-01 04:48:36 UTC
Created attachment 112559 [details]
fixes the warnings

Comment 2 Colin Charles 2005-04-01 04:49:01 UTC
Apply patch, rebuild thanks

Comment 3 Bastien Nocera 2005-04-02 14:11:12 UTC
Fixed in CVS.

2005-04-02  Bastien Nocera  <hadess@hadess.net>

        * src/soundcard.py: remove use of deprecated gtk.FALSE and gtk.True
        (Closes: #153053)
        * src/soundcardBackend.py: scan the ISA bus (Closes: #146888), and the
        MacIO bus. Also set the "DRC Range" mixer to on for Macs
        (Closes: #146357)



Note You need to log in before you can comment on or make changes to this bug.