Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153043 - fails to start because looking for /sbin/lvm, should be /usr/sbin/lvm
Summary: fails to start because looking for /sbin/lvm, should be /usr/sbin/lvm
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-lvm
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Jim Parsons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-01 04:07 UTC by Ricky Ng-Adam
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-08 05:09:19 UTC


Attachments (Terms of Use)

Description Ricky Ng-Adam 2005-04-01 04:07:16 UTC
Description of problem:

Traceback (most recent call last):
  File "/usr/share/system-config-lvm/system-config-lvm.py", line 131, in ?
    runFullGUI()
  File "/usr/share/system-config-lvm/system-config-lvm.py", line 116, in runFullGUI
    blvm = baselvm(glade_xml, app)
  File "/usr/share/system-config-lvm/system-config-lvm.py", line 70, in __init__
   self.volume_tab_view = Volume_Tab_View(glade_xml, self.lvmm, self.main_win)
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 131, in __init__
    self.prepare_tree()
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 203, in prepare_tree
    vg_list = self.model_factory.query_VGs()
  File "/usr/share/system-config-lvm/lvm_model.py", line 314, in query_VGs
    result_string = rhpl.executil.execWithCapture("/sbin/lvm",arglist)
  File "/usr/lib/python2.4/site-packages/rhpl/executil.py", line 105, in
execWithCapture
    raise RuntimeError, command + " can not be run"
RuntimeError: /sbin/lvm can not be run

[root@localhost ~]# which lvm
/usr/sbin/lvm

Version-Release number of selected component (if applicable):

0.9.18-1.1

How reproducible:

always 

Steps to Reproduce:
1. start program
2.
3.
  
Actual results:

fail with exception

Expected results:

full gui or if not, should at least fail graciously with a gui popup

Additional info:

Comment 1 Ricky Ng-Adam 2005-04-08 05:08:35 UTC
ok, fixed in system-config-lvm-0-0.9.22-1


Note You need to log in before you can comment on or make changes to this bug.