Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153036 - GtkDeprecationWarning: gtk.FALSE, gtk.TRUE
Summary: GtkDeprecationWarning: gtk.FALSE, gtk.TRUE
Keywords:
Status: CLOSED DUPLICATE of bug 153033
Alias: None
Product: Fedora
Classification: Fedora
Component: firstboot
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-01 03:48 UTC by Ricky Ng-Adam
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-01 06:07:17 UTC


Attachments (Terms of Use)

Description Ricky Ng-Adam 2005-04-01 03:48:37 UTC
Description of problem:

/usr/share/firstboot/modules/boot_gui.py:70: GtkDeprecationWarning: gtk.FALSE is
deprecated, use False instead
  self.bootView.set_property("headers-visible", gtk.FALSE)
/usr/share/firstboot/modules/boot_gui.py:82: GtkDeprecationWarning: gtk.FALSE is
deprecated, use False instead
  self.myHbox.pack_start(self.timeoutLabel, gtk.FALSE)
/usr/share/firstboot/modules/boot_gui.py:83: GtkDeprecationWarning: gtk.FALSE is
deprecated, use False instead
  self.myHbox.pack_start(self.timeoutEntry, gtk.FALSE)
/usr/share/firstboot/modules/boot_gui.py:164: GtkDeprecationWarning: gtk.FALSE
is deprecated, use False instead
  self.bootView.set_cursor(path, self.col, gtk.FALSE)
/usr/share/firstboot/modules/boot_gui.py:165: GtkDeprecationWarning: gtk.TRUE is
deprecated, use True instead
  self.bootView.scroll_to_cell(path, self.col, gtk.TRUE, 0.5, 0.5)
/usr/share/firstboot/modules/boot_gui.py:97: GtkDeprecationWarning: gtk.TRUE is
deprecated, use True instead
  self.myVbox.pack_start(self.bootViewSW, gtk.TRUE)
/usr/share/firstboot/modules/boot_gui.py:98: GtkDeprecationWarning: gtk.FALSE is
deprecated, use False instead
  self.myVbox.pack_start(self.myHbox, gtk.FALSE)
/usr/lib/python2.4/site-packages/rhpl/firstboot_gui_window.py:130:
GtkDeprecationWarning: gtk.FALSE is deprecated, use False instead
  iconBox = gtk.HBox(gtk.FALSE, 5)
/usr/lib/python2.4/site-packages/rhpl/firstboot_gui_window.py:137:
GtkDeprecationWarning: gtk.TRUE is deprecated, use True instead
  msgLabel.set_line_wrap(gtk.TRUE)
/usr/lib/python2.4/site-packages/rhpl/firstboot_gui_window.py:141:
GtkDeprecationWarning: gtk.FALSE is deprecated, use False instead
  toplevel.pack_start(iconBox, gtk.FALSE)
/usr/lib/python2.4/site-packages/rhpl/firstboot_gui_window.py:142:
GtkDeprecationWarning: gtk.TRUE is deprecated, use True instead
  toplevel.pack_start(self.myVbox, gtk.TRUE)


Version-Release number of selected component (if applicable):

0.2.8-1

How reproducible:

always

Steps to Reproduce:
1. start program at console
2.
3.
  
Actual results:

extraneous warnings

Expected results:

no warnings

Additional info:

Most system-config-* have the same problems, I'm opening a bug for each.

Comment 1 Colin Charles 2005-04-01 06:07:17 UTC
Definitely not system-config-boot, this is firstboot at action, and there's a
duplicate too for #153033

*** This bug has been marked as a duplicate of 153033 ***

Comment 2 Harald Hoyer 2005-04-01 10:17:06 UTC
/usr/share/firstboot/modules/boot_gui.py was fixed in system-config-boot-0.2.9-1


Note You need to log in before you can comment on or make changes to this bug.