Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153035 - GtkDeprecationWarning: gtk.FALSE, gtk.TRUE
Summary: GtkDeprecationWarning: gtk.FALSE, gtk.TRUE
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-bind
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-01 03:45 UTC by Ricky Ng-Adam
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 4.0.0-7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-05 00:01:47 UTC


Attachments (Terms of Use)
fixes the warnings (deleted)
2005-04-01 05:24 UTC, Colin Charles
no flags Details | Diff

Description Ricky Ng-Adam 2005-04-01 03:45:10 UTC
Description of problem:

/usr/share/system-config-bind/ZoneTree.py:914: GtkDeprecationWarning: gtk.TRUE
is deprecated, use True instead
  s.tree.set_reorderable(gtk.TRUE)
/usr/share/system-config-bind/ZoneTree.py:894: GtkDeprecationWarning: gtk.FALSE
is deprecated, use False instead
  w.pack_start(l,gtk.FALSE)
/usr/share/system-config-bind/ZoneTree.py:897: GtkDeprecationWarning: gtk.FALSE
is deprecated, use False instead
  w.pack_start(s.search_value,gtk.FALSE)
/usr/share/system-config-bind/ZoneTree.py:905: GtkDeprecationWarning: gtk.FALSE
is deprecated, use False instead
  s.showDNSSEC.set_active(gtk.FALSE)

Version-Release number of selected component (if applicable):

4.0.0-4.4

How reproducible:

always

Steps to Reproduce:
1. start program at console
2.
3.
  
Actual results:

extraneous warnings

Expected results:

no warnings

Additional info:

Most system-config-* have the same problems, I'm opening a bug for each.

Comment 1 Colin Charles 2005-04-01 05:23:04 UTC
Attached patch fixes all possible warnings thru the entire code
(s/gtk.TRUE/True/g) and so on. Apply them, and rebuild so the warnings disappear.

Comment 2 Colin Charles 2005-04-01 05:24:28 UTC
Created attachment 112569 [details]
fixes the warnings

Comment 3 Jason Vas Dias 2005-04-04 14:11:37 UTC
This bug was caused by pygtk2-2.6.0 .
It is now fixed in system-config-bind-4.0.0-7 .



Note You need to log in before you can comment on or make changes to this bug.